Update user settings using API

Trying to update user settings using the API details below. It returns 204 (success?) but the user settings are not updated.


PATCH : https://api.zoom.us/v2/users/{emailAddress}
Body:
{
“feature”: {
“large_meeting”: true
}
}

HTTP status : 204

Response : Null


Looking for help.

Thank you for posting in the Developer Forum, @ycd! When I updated the “large_meeting” property in the feature object, using the exact same request body payload, the user setting is updated as expected. Here is a video showing it is working as expected:

Example Request:

Patch https://api.zoom.us/v2/users/{{zoomie-email}}/settings

{
  "feature": {
        "large_meeting": true
    }

}

Thanks Donte, I do get the 204 back however, the UI does not show the update. Can you please check the UI to see if the update is reflecting there?

The GET call gives partial results back. I cannot verify the user settings from the GET call. See below. I could be missing a scope?

{
“id”: “-",
“first_name”: "Y
",
“last_name”: "C
",
“email”: ".com",
“type”: 2,
“role_name”: “Member”,
“pmi”: ,
“use_pmi”: false,
“personal_meeting_url”: "Join Meeting - Zoom
",
“timezone”: “America/Los_Angeles”,
“verified”: 0,
“dept”: “”,
“created_at”: “2019-01-21T21:16:16Z”,
“last_login_time”: “2022-04-26T02:34:21Z”,
“last_client_version”: "
*****",
“host_key”: "
",
“cms_user_id”: “”,
“jid”: “-xmpp.zoom.us",
“group_ids”: [],
“im_group_ids”: [
"

],
“account_id”: "
",
“language”: “en-US”,
“phone_country”: “”,
“phone_number”: “”,
“status”: “active”,
“job_title”: “”,
“location”: “”,
“custom_attributes”: [
{
“key”: "
************”,
“name”: “Phone”,
“value”: “”
}
],
“login_types”: [
101
],
“role_id”: “2”,
“account_number”: ******
}

Yes, I can confirm the change is reflected in the UI. Also, that does not look Get User Setting Response payload. I’ve linked the API below, can you try again and share the results with us :

Get user settings API LINK

Thanks for the quick reply,
Here are the details, I confirm.

GET :https://api.zoom.us/v2/users/@.com/settings
Response: (partial)
{“meeting_capacity”:500,
“large_meeting”:false*,“webinar”:false,“zoom_events”:false,“cn_meeting”:false,“in_meeting”:false,“zoom_phone”:false,“concurrent_meeting”:“None”,“zoom_iq_for_sales”:false},

Hi, @ycd,

Can you share if you are using the JWT or OAuth Access token when making your request? You should be able to get back the entire response, not partial.

Hi Donte, sorry for the late reply, I was helped on this topic by you through a support case.
The issue was, I was using a wrong endpoint url. The “/settings” was missing at the end.