[Urgent] Camera doesn't work after upgrading from SDK 1.1.2 to 1.2.0+


Description
Our clients run a custom hardware - a few of them run Android 7.1 while a few of them run Android 5.0. Zoom Video SDK 1.1.2 works perfectly for us, but after we upgraded it to 1.2.0, we noticed that the user’s camera fails to capture the video which causes the remote user to not see anything on their end. This is only happening on hardware which runs Android 5.0, it works fine on Android 7.1. We’ve also tried Video SDK 1.5.2 which is the latest one, but the same problem persists.

Also, when we manually try to toggle the camera using ZoomVideoSDK.getInstance().videoHelper.startVideo() , we get an Errors_Internal_Error error. I’ve uploaded the Zoom logs here: zoom.log - Google Drive

I’ve marked it as urgent only since Zoom seems to be enforcing minimum version policy of 1.2.0 from November 5th which could cause an outage for our users since 1.2.0 and above is not working properly for us.

Which Android Video SDK version?
Tried 1.2.0 as well as the latest one which 1.5.2

Smartphone (please complete the following information):

  • Device: Custom Hardware
  • OS: Android 5.0

Hi Zoom team,
Is there an update to this? It’s a significant problem for us.
Some response would be greatly appreciated
Thanks