URL Validation for Splunk Webhook

API Endpoint(s) and/or Zoom API Event(s)
Webhook only application

Hi There,
We are trying to set up a Zoom webhook into Splunk and were able to get the webhook working successfully. We were able to validate the URL, it was validated successfully but fails to validate every 72 hours as is now required. Has anyone run into this problem?

Event notification endpoint URL
Provide a URL to receive subscribed event notifications. This is for your production environment.
URL validation failed. Try again later.

How To Reproduce
Steps to reproduce the behavior:
*1. URL Validation worked at one point but now is no longer
2. I don’t see where I can see logs for this validation attempt
3. According to our team we have created a URL validation found here:

Does anyone have any suggestions on where to see more logs than just what is shown in the app marketplace? I am not seeing anything related to URL validation in the webhook logs.

Hi @michael.miller2
Welcome to the Zoom Developer Forum and to our community! I am glad you are here!

Sorry for the late response here!
Are you still experiencing this issue? Or are you not running into this issue anymore?

Feel free to share as many details as you want


Hi Elisa,

Yes, thank you for the response.

Yes periodically it seems that the webhook URL validation will fail, we can’t really determine why it’s failing though, is there anyway to see logs on the URL validation? I don’t see anything in the webhook logs.

Could this be due to network congestion? It seems to work at random times and fail at others.

Hi @michael.miller2
Thanks for confirming this.
When you start seeing this error, do you still get events or do you have to revalidate your endpoint?

Hi Elisa,

Thank you for your response and sorry for the delay in getting back to you.

When it fails I have to revalidate the endpoint and it will succeed periodically but fails other times.

I noticed this time it stayed at active for almost a month and a half and then I got a notification it didn’t automatically revalidate and that it would be disabled after 2 more tries. So I let it try again and it finally stopped working after 15 more days.

Now I can’t seem to get it revalidate. Nothing has changed in the environment.

Thank you,

Hi @michael.miller2
Interesting, so have you not been able to validate the endpoint since the last time it failed?

Hi Elisa,

Thank you for the response, I was able to get validated today randomly after clicking revalidate 4 or 5 times.

It’s pretty tough to troubleshoot, I don’t see anywhere in the logs where this revalidation request is sent.

Any ideas where else to look?

Thank you,

Thank you @michael.miller2
Are you able to see any error logs in your terminal when you are validating the endpoint?
The validation request challenge should be sent to your endpoint

This is due to the fact Splunk doesn’t not support responding to URL vertification. We have been unable to make any changes to ours to avoid loosing this logging as well it is mission critical to our business function and trying to plan for it’s inevitable change in August.

Hi @elisa.zoom,
I am still having quite a bit of trouble with this, for some reason today, even thought the link is validated, now all traffic is no longer reaching splunk and I am getting a 503 error in my webhook logs. Would you be able to suggest any ideas for what to check to fix this?
Thank you again for your help.