What's wrong with my signature?

Signature is invalid

Which version?


@tommy Sorry for bumping to you Tommy, but I have an event scheduled in a couple weekends and really need to get this Web SDK working since iFrames are no longer supported. I’ve tried multiple ways to get a valid signature and can’t even get the sample CDN web sample working.

I have my signature being generated from a php page here:
Each time you hit this page; it’ll generate a new signature which I have index.js from the sample calling to obtain the signature.

Hey @jeremysh,

Thanks for sharing your signature generator and describing the error you’re running into. Just to make sure we’re on the same page, you’re intending to join a meeting using this signature, correct? (I see you’re passing role ‘0’ into the signature currently, which is to join. (Starting a meeting is role ‘1’—if this is what you’re intending to do, just let me know)

If joining is your intention, can you ensure that the meeting with the ID in your signature already exists in Zoom and has been started before you attempt to join?


Yes, Meeting has been started and verified the ID is correct. I also tried setting role=1 when the meeting hadn’t been started yet which also still threw the signature error.

Hey @jeremysh,

Looks like you are using an SDK App to generate the Web SDK signature.

You need to use a JWT App instead. Also, make sure you have a Pro or higher Zoom account.

Let me know if that helps! :slight_smile:


Ok, I created a JWT App and updated my api key/secret in my code.
I also made myself the Licensed user; in the managed user section of my company account.

Here’s a sample of an updated signature:


My index.js (slightly modified from sample)

Maybe I just start fresh building my own instead of trying to get the sample working.

Ok tried to create a very simple sample… Getting the following error:
zoom-meeting-1.8.0.min.js:2 Uncaught TypeError: Cannot read property ‘0’ of null
at w (zoom-meeting-1.8.0.min.js:2)
at redux.min.js:1
at a (redux.min.js:1)
at redux-thunk.min.js:1
at Object.zmg_initMeetingConfig (redux.min.js:1)
at c.value (zoom-meeting-1.8.0.min.js:2)
at O (zoom-meeting-1.8.0.min.js:2)
at Object.init (zoom-meeting-1.8.0.min.js:2)
at zoom.js:13

// zoom.js CDN version default

ZoomMtg.setZoomJSLib(‘https://dmogdx0jrul3u.cloudfront.net/1.8.0/lib’, ‘/av’);



var mySignature = “”;


.then(res => res.text())

.then(data => mySignature = data)

.then(() => console.log("mySignature: " + mySignature));


leaveUrl: "/",

isSupportAV: false,

success: function() {


        signature: mySignature,

        meetingNumber: '',

        apiKey: '',

        passWord: '',

        success: (success) => {



          error: (error) => {






I guess leaveUrl can’t be “/”. That was throwing this error.

Hey @jeremysh,

Yes the leaveUrl must be a valid Url like https://zoom.us

Were you able to get the whole app working?


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.