Zoom duration is not over as expected

Hi, I have JWT Token to integrate Zoom API with my online class application. I know if the basic account only have 40 minutes max for meeting. But, when I create a meeting with 10 minutes of duration for sample. The duration seems not working, because the meeting still running even more than 10 minutes. Any help?

Note: I use a scheduled meeting type

Hi, @ramawidi,

Thank you for posting in the Zoom Developer Forum. Can you confirm how the meeting is being ended ? Also, are you able to share a screenshot of the Json response body where the meeting duration exceeds 10 minutes ? You can use our Get Meeting API to retrieve the details of a meeting:

Best,
Donte

Hi. Sorry for late response. And thank you for your reply.
Here is my JSON response after create meeting:

{
uuid: ‘[REACTED]’,
id: 81900182885,
host_id: ‘[REACTED]’,
host_email: ‘<my_email>’,
topic: ‘Test 1’,
type: 2, // Scheduled meeting type
status: ‘waiting’,
start_time: ‘2021-06-01T02:00:00Z’,
duration: 15, // => This example duration
timezone: ‘Asia/Jakarta’,
agenda: ‘Test 1’,
created_at: ‘2021-05-31T01:33:47Z’,
start_url: ‘<start_url>’,
join_url: ‘<join_url>’,
password: ‘12345’,
h323_password: ‘12345’,
pstn_password: ‘12345’,
encrypted_password: ‘[REACTED]’,
settings: {
host_video: true,
participant_video: true,
cn_meeting: false,
in_meeting: false,
join_before_host: false,
jbh_time: 0,
mute_upon_entry: false,
watermark: false,
use_pmi: false,
approval_type: 2,
audio: ‘both’,
auto_recording: ‘none’,
enforce_login: false,
enforce_login_domains: ‘’,
alternative_hosts: ‘’,
close_registration: false,
show_share_button: false,
allow_multiple_devices: false,
registrants_confirmation_email: true,
waiting_room: true,
request_permission_to_unmute_participants: false,
global_dial_in_countries: [ ‘US’ ],
global_dial_in_numbers: [ [Object], [Object], [Object], [Object], [Object], [Object] ],
registrants_email_notification: true,
meeting_authentication: false,
encryption_type: ‘enhanced_encryption’,
approved_or_denied_countries_or_regions: { enable: false },
breakout_room: { enable: false },
alternative_hosts_email_notification: true,
device_testing: false
}
}

The response for duration is 15 minutes. But the meeting is still running more than 15 minutes. Here is the screen shoot

Hey @ramawidi,

Thanks for providing more information. When you set the duration of a meeting, that just indicates how long you plan for the meeting to be. This is used for scheduling purposes for the event.

However, the meeting will not end if it exceeds that duration. If you wanted to automatically end a meeting at the duration, you could use our Update Meeting Status API.

Let me know if that helps.

Thanks,
Max

Oh, I see. So it’s my miss understanding about that. Thank you for your help

Glad Max was able to help! :slight_smile: