Zoom OAuth2 Authroize takes to login redirect url

I created a test app in marketplace and trying to create webinar using salesforce UI. When I call authorize, I am redirected to zoom login url instead of redirecturl/$code. How do I get salesforce to auto login and redirect me directly to redirecturl/$code?

This is the URL:Error - Zoom
I get HTML body for the redirect url with error . [Javascript is enabled in my chrome browser].

I am able to get this working in postman.

Hey @nithishaprasad,

Thank you for reaching out to the Zoom Developer Forum. Please make sure that you’re including the client_id when making this request. I’ve included an example from out OAuth Documentation below.

https://zoom.us/oauth/authorize?response_type=code&client_id=7lstjK9NTyett_oeXtFiEQ&redirect_uri=https://yourapp.com

I hope that helps! Let me know if you have any questions.

Thanks,
Max