Zoom Rooms - Sensor_data error

I’ve tried to get ensor_data from Zoom Room for Appliances devices.

Zoom Rooms Controls method works fine with same credential, however, I could not get Sensor Data.
It returns
“code”: 1012,
“message”: “Room does not exist: 2RcQbFGXRLiDU3x_WXpGxw.”

Rooms should exist since I can get room information by api.zoom.us/v2/rooms/2RcQbFGXRLiDU3x_WXpGxw/

Do I need extra paramters to use “GET /rooms/{roomId}/sensor_data”?

Hi Yuki,

Have you tried using “id” instead of “room_id”?


I tried “id” today. It works.

"from": "2023-01-06T00:39:51Z",
    "to": "2023-01-07T00:39:51Z",
    "next_page_token": "Rl6DuWkIGePEemqThUZWfmUCB3P0JdBzwm2",
    "page_size": 30,
    "total_records": 1440,
    "sensor_data": [
            "date_time": "2023-01-06T00:40:28Z",
            "device_id": "neat-ND12209000355",
            "sensor_type": "REAL_TIME_PEOPLE_COUNT",
            "sensor_value": "0"
            "date_time": "2023-01-06T00:40:28Z",
            "device_id": "neat-ND12209000355",
            "sensor_type": "TEMPERATURE",
            "sensor_value": "24.1"

So should we use {Id} instead of {roomId}?
GET /rooms/{roomId}/sensor_data

Apologize for the inconvenience.
Please use the “id” for now and meanwhile we will correct the document.

Best regards,