zoomMtg.join never reach success nor error

I saw there are a lot of topics regarding “cannot joining the meeting”, yet still couldn’t resolve my issue even after I read and applied the solutions.

The issue I encounter is zoomMtg.join never reach success nor error function. After the init success, then user click on “join” button, then zoom only shows spinner loading forever “Joining Meeting…”.

I tried to upload the screenshot image but there is a error message I couldn’t upload media on this post.

Which Web Meeting SDK version?

To Reproduce(If applicable)
Sorry I couldn’t provide STR at the moment.


Device (please complete the following information):

  • Device: Macbook
  • OS: MacOS Big Sur 11.4
  • Browser: Chrome
  • Browser Version 93.0.4577.82 (Official Build) (x86_64)

Additional context

const meetConfig = {
    signature: generateSignature({
      apiKey: process.env.ZOOM_API_KEY,
      apiSecret: process.env.ZOOM_API_SECRET,
      meetingNumber: hiddenNumber,
      role: 0,
      success: (res) => {
    apiKey: process.env.ZOOM_API_KEY,
    meetingNumber: hiddenNumber,
    leaveUrl: "hidden",
    userName: 'hidden',
    userEmail: 'hidden',
    passWord: 'hidden',
    success: (success) => {
      console.log('Joining meeting Success');
      console.log('joining: ', success);
    error: (error) => {
      console.log('Joining meeting Error');
      console.log('joininig: ', error);

  const zoomInitConfig = {
    debug: true,
    leaveUrl: 'http://www.zoom.us', //required
    webEndpoint: 'PSO web domain', // PSO option
    showMeetingHeader: false, //option
    disableInvite: false, //optional
    disableCallOut: false, //optional
    disableRecord: false, //optional
    disableJoinAudio: false, //optional
    audioPanelAlwaysOpen: true, //optional
    showPureSharingContent: false, //optional
    isSupportAV: true, //optional,
    isSupportChat: true, //optional,
    isSupportQA: true, //optional,
    isSupportPolling: true, //optional
    isSupportBreakout: true, //optional
    isSupportCC: true, //optional,
    screenShare: true, //optional,
    rwcBackup: '', //optional,
    videoDrag: true, //optional,
    sharingMode: 'both', //optional,
    videoHeader: true, //optional,
    isLockBottom: true, // optional,
    isSupportNonverbal: true, // optional,
    isShowJoiningErrorDialog: true, // optional,
    disablePreview: false, // optional
    disableCORP: true, // optional
    inviteUrlFormat: '', // optional
    loginWindow: {  // optional,
      width: 400,
      height: 380
    meetingInfo: [ // optional
    disableVoIP: false, // optional
    disableReport: false, // optional
    success: (res) => {
      console.log('init success: ', res);
    error: (error) => {
      console.log('init failed: ', error);

  const openZoom = async () => {
    await setIsShowModal(true);
    if (typeof document.getElementById("zmmtg-root") !== "undefined") {
      const { ZoomMtg } = await import("@zoomus/websdk");
      await ZoomMtg.checkSystemRequirements();
      await ZoomMtg.setZoomJSLib('https://source.zoom.us/1.9.8/lib', '/av');
      await ZoomMtg.preLoadWasm();
      await ZoomMtg.prepareJssdk();

Hey @Darryl_RN ,

The issue is you are passing the leaveUrl into the ZoomMtg.join() function object. It should be passed into the ZoomMtg.init() function object instead. :slight_smile:



Hi @tommy ,
thank you for your reply, it works after I removed leaveUrl in ZoomMtg.join(),
however it goes to another error Joining meeting failed with

You have been limit by zoom, verfy recaptcha and try again, open https://PSO web domain

How to resolve this?

Hey @Darryl_RN , glad to hear we are making progress! :slight_smile:

Try removing the webEndpoint property and see if that fixes the issue.


Thanks @tommy I think its getting closer.
This time the error message is different.

It says no permission, I’ve started the meeting, yet it still shows the same error below…

Idk why I couldn’t upload image, then after I posted imgbb two times in this thread, I’m no longer able to post imgbb url.

Hey @Darryl_RN ,

This is most likely an issue with your signature. Can you please send it to developersupport@zoom.us with a link to this thread so we can take a look? :slight_smile:


Hi @tommy, thank you for your suggestion, I have sent the information with the link to this post/thread.
will inform if there is any update.

Btw, I wonder if the solution is not appear publicly?
I saw many similar post regarding web SDK, but couldn’t find the correct solution.
Yet, this post was marked as spam? Is it bcs I used imgbb to post the image?

anyway, thanks for your help.
hope I could resolve the issue soon.

Hey @Darryl_RN ,

Thanks, I just replied to you! :slight_smile:

I resolved the spam issue by the way.


(post deleted by author)