400 Bad Request on creating recurring meeting

Description
i’m getting bad request 400 with when trying to create recurring meeting, and it was working before but suddenly it gives me this error and when i try to create a normal meeting it works without error

Error
{
“code”: -1,
“message”: null
}
Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
POST https://api.zoom.us/v2/users/01207943753@realsofthouse.com/meetings

How To Reproduce (If applicable)
this is the body of the request

{
“topic”: “Mon Ms Asmaa Ashour 7.30 To 9.30 INTRO”,
“type”: 8,
“password”: “759648”,
“start_time”: “2020-12-21T19:30:00”,
“duration”: 120,
“timezone”: “Africa/Cairo”,
“recurrence”: {
“type”: 2,
“weekly_days”: “2,5”,
“end_times”: 12
}
}

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
it not working either on your send test request from zoom api platform

Hey @ahmedraafat200,

Thank you for reaching out to the Zoom Developer Forum. Just to clarify, you’re using the same JWT token for both requests and only the recurring meeting request fails? Do you ever see an error message other than the null message that you provided? Are you able to create meetings for your own user?

Thanks,
Max

we generate new JWT for every request, and every request working as intended even if you tried to create instant meeting through the api it works perfectly

and we are working with the same api requests for the last 8 months, and it was working just fine
and suddenly now we can’t create scheduled meeting through api

Hey @ahmedraafat200,

Thank you for the update. One thing I’m seeing is that there isn’t a repeat_interval in the recurrence section. From what I understand, the repeat_interval property is required when you choose a recurrence type of 2. Please test including the property and let me know if that resolves your issues.

Thanks,
Max

Hey @ahmedraafat200,

Thank you for your patience. As an update, I’ve also reached out to our engineering team in regard to this issue. As soon as I have more information from them I’ll update you. In the meantime, please test if the aforementioned change resolves your issue. (ZOOM-230964)

Thanks,
Max

Hey @ahmedraafat200,

For the create Meeting API bug (error code 400 “-1” “null”) a workaround until we fix it is to pass the settings field and approval type in the API request. For example:

{
   ...
   "settings": {
      "approval_type":"{respective value here}"
   }
}

Please let us know if that helps! :slight_smile:

Thanks,
Tommy

1 Like

Thanks, it worked with this workaround

1 Like

Hey @ahmedraafat200,

I’m glad to hear that @tommy resolved your issues! If you encounter any further issues or questions, please don’t hesitate to reach out.

Thanks,
Max

1 Like

Hey @ahmedraafat200,

Just letting you know this issue will be fixed this weekend on the 9th. You will no longer have to use the work around after the 9th. :slight_smile:

Thanks,
Tommy