Alternate Host and Password Assigned to Instant Meetings with PMI Enabled

We enabled “Use PMI while creating Scheduled & Instant Meetings”. When we create a new scheduled meeting using API and pass the alternate Host id and Meeting password, it applies it to all scheduled and Instant Meetings. When I create a new Instant meeting, the alternate host set for that old meeting gets a notification and gets added again. Is this intended?

Which Client Windows SDK version?
Version: 5.5.2 (12494.0204)

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Enable Use Personal Meeting ID (PMI) when starting an instant meeting
  2. Schedule a meeting using API and add an alternate host.
  3. Now go to Windows Application for Zoom and schedule a meeting. The alternate host is already added there.
  4. If you click on the down arrow for “New Meeting” > Click on PMI > PMI Settings > Advanced Setting > The alternate host is already added.


Hi @vsehgal,

Thanks for reaching out about this, and good question. This does appear to be intended behavior, and I believe this is related to the behavior discussed in this thread:

Let me know if this helps to clarify—thanks!

Hi Will,

Thanks for confirming that, its helpful!

Is there a way to not have it update all the meetings? I saw a note and a link to “Revert Settings” while doing this in the web-application itself:

Is there a flag in API for this “Revert Setting” action?


Hey @vsehgal,

Good question—while this is a great suggestion, I’m afraid the API doesn’t support this. However, I can certainly appreciate the use case. If you’re so inclined, you might consider adding a feature request for this here: #feature-requests


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.