Use_pmi for schedule room meeting

I am going to schedule a meeting for rooms and I defined “use_pmi”: true, but it is still generating random meeting ID instead of using room meeting ID, I tried to change my account settings to
“use_pmi_for_scheduled_meetings”: true,
“use_pmi_for_instant_meetings”: true,

but still, it is not creating a scheduled room meeting with room meeting id.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

My codes:


“jsonrpc”: “2.0”,

“method”: “schedule”,

“params”: {

"callback_url": "",

"meeting_info": {

  "topic": "Meeting API",

  "start_time": "2020-07-29T19:31:00",

  "timezone": "America/New_York",

  "duration": "10",

  "settings": {

    "join_before_host": false,

    "use_pmi": true





Could someone please help me to schedule a room meeting with my room meeting ID or some constant meeting ID?

Thank you so much!

Hey @Drensys,

According to our docs, the Schedule Zoom Room API does not have the use_pmi property:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.