An error occurred while embedding the SDK

An error occurred while embedding the SDK
error: Embedded binary is not signed with the same certificate as the parent app. Verify the embedded binary target’s code sign settings match the parent app’s.

Embedded Binary Signing Certificate: Developer ID Application: Zoom Video Communications, Inc. ()
Parent App Signing Certificate: Mac Developer: Name ()

I tried deleting and generating the binary again, but no luck, i also tried to remove my certificate attached to none, but then also same error.


Hi @15604510000,

Thanks for the post. You will need to re-sign all the lib files in the SDK to avoid this issue.

Hope this helps. Thanks!

How to resign all the lib file in the sdk folder. please provide step by step procedure.

Thank you for your reply. The problem has been solved

Hi @15604510000,

Glad to hear that it is solved. Happy Zooming :slight_smile:

Hi @anupsoni,

You could use the command codesign in the terminal to sign a lib. Here is an instruction from Apple:


Can you provide some example to use this command? Take example of zoomSDK folder lib.

Hello, are you also using a custom UI? I have a signature modification program. Do you need it? How can I give it to you?

no, I am not using custom ui.