Unable to run Mac app

I downloaded zoom sdk mac sample from here. - https://github.com/zoom/zoom-sdk-macos
when i tried to run it - the project fires an error -

error: unexpected service error: build aborted due to an internal error: unable to write manifest to ‘/Users/username/Downloads/zoom-sdk-macos-master/ZoomSDKSample/…/…/…/…/…/…/…/…/Bin/Mac/XCBuildData/5aaff50138f95afa577a2e0a15f66d27-manifest.xcbuild’: mkdir(/Users/username/Downloads/zoom-sdk-macos-master/ZoomSDKSample/…/…/…/…/…/…/…/…/Bin/Mac, S_IRWXU | S_IRWXG | S_IRWXO): Operation not permitted (1)

can you please give some lead .

Hi dev-admin-demo,

Thanks for the post. Please change the following: File -> Project Settings -> Build Systems -> Legacy Build System and try again.

Hope this helps. Thanks!

Thanks a lot for a quick reply, saved me a lot of time.

This worked, but one more error appeared which is related to certificates,
error: Embedded binary is not signed with the same certificate as the parent app. Verify the embedded binary target’s code sign settings match the parent app’s.

Embedded Binary Signing Certificate: Developer ID Application: Zoom Video Communications, Inc. (BJ4HAAB9B3)
Parent App Signing Certificate: Mac Developer: Name (ID****JSJ)

I tried deleting and generating the binary again, but no luck, i also tried to remove my certificate attached to none, but then also same error.


Thanks, i just re-downloaded the sample project and did all previous settings, and it worked :slight_smile:

Thanks a lot.

Hi dev-admin-demo,

Glad to hear that it is working now. Happy Zooming! :slight_smile: