Android : How to remove annotations when the screen is shared

Description
When the host is sharing the screen, am getting a pencil icon at the screen left bottom and using that I can draw on the screen, how to remove that option. I have attached screenshot for reference. Am using default UI.

Hi @vignesh, thanks for the post.

The annotation toolbar can be hidden by calling hideAnnotationInScreenShareToolbar.

Thanks!

Hello @jon.lieblich ,
I have tried it and set it to false, but I still see the tool bar when screen is shared.

Hi @vignesh,

In order to hide it, please set it to true. The parameter is indicating whether or not you would like to hide the toolbar. :slightly_smiling_face:

Thanks!

Hello @jon.lieblich ,
I tried setting it to true, I still see the annotation toolbar.

Hi @vignesh,

Can you please provide a screenshot of the toolbar you are seeing? This feature is working as expected for me.

Thanks!

@vignesh The host can call InMeetingAnnotationController.disableViewerAnnotation to disable viewer annotaion. disable viewer annotaion will not show annotation button.

Or You can disable annotaion feature by web settings.

Thanks

Hello @jon.lieblich ,
This is the toolbar am seeing.

@Fred_Luo but my app is targeted to members not the host.

Hi @vignesh,

The SDK currently only supports controlling annotation appearance for the host through the methods referenced previously in this thread. To hide it for participants, the setting must be turned off for the meeting as a whole.

Thanks!

Hello @jon.lieblich ,
I have attached the screenshot of the setting page, that am seeing, but I cannot able to disable to annotation, can you please guide me ?

Hi @vignesh,

The Annotations setting in that screenshot has a switch next to it. Click on that switch and annotations will be turned off.

Thanks!

Hello @jon.lieblich,
Worked like a charm, thanks a lot.

Glad to hear it’s working!

Please reach out in a new post if you require any additional help. :slightly_smiling_face:

Sure @jon.lieblich, thanks a lot.

You are very welcome!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.