Android Zoom meeting SDK crash after upgrade to

Hi, @ezarstage @dmitryukhanov , this issue might be due to the incompatible version of androidx.core. Can you please navigate to the project root directory, and run
./gradlew dependencies
then send us build log. Thank you!

1 Like

How do I paste a text file here? If I just copy text here, the character limit gets in the way.

Hi @dmitryukhanov , just reached out to you for you to message me the text file.

Logs shared with @qing.peng , awaiting next steps!

Hello @dmitryukhanov , @ezarstage – we are investigating further (ZSEE-107312, ZSEE-107311). Thanks for your patience!

Posting in case it’s relevant to anyone:

Hi @ezarstage , are you able to provide APK?

Could this be related?

Hi @kaitlynnst it could be related! I’ll respond more in that particular thread. Thanks!

I run into this issue while integrating Zoom Meeting SDK with react-native.

  • v5.13.10 always worked fine
  • v5.14.0 crashes after joining meeting
  • I also tried with newest versions of Zoom Meeting SDK - and react-native - 0.72.6 and I am still getting crashes

I discovered that in Android Studio, when:

  • I use Run 'app' - it never crashes
  • However, when I do Build -> Build Bundle(s) / APK(s) -> Build APK(s) and installing .apk on the phone - it always crashes

Any idea why there might be a difference between Run 'app' and Build?

1 Like

Hi @mieszko4 , can you please do a test to set minifyEnabled to be false, and see if the crash still exist? Thanks!

It was already false when I tried it. So the issue must be something else.
But thnx for the suggestion!

@mieszko4 Got it, thanks for confirmation! We noticed that there is a similar issue which is resolved by upgrading gradle version: [BUG] java.lang.NoSuchMethodError: No static method $private$all(Landroidx/compose/ui/layout/ParentDataModifier;Lkotlin/jvm/functions/Function1;) · Issue #5345 · stripe/stripe-android · GitHub

Can you please provide us the version of gradle and gradle plugin in your project? Thanks!

1 Like

Hey @mieszko4 I am already using your react-native-zoom-us package. but for the Picture in Picture issue, I tried to manually upgrade SDK to v5.16.2, but with your jitpack version which is v5.16.2.16555 I am facing the same issue that you mentioned above. it is happening the same as you described working only with the studio’s run button.

@gianni.zoom Any help from your side as well will be appreciated, thanks.

Appologies for late reply.
I am using gradle-8.0.1 and
My project also uses react-native@0.72.2.



For Gradle version, i am using 8.2

and for Gradle plugin version is not specified
dependencies {

@mieszko4 Can you please upgrade to 7.1.2 to see if it solves the problem? Thanks.

1 Like

Updating to 7.1.2 did not help.

What helped was setting minSdkVersion to 24.
That means, however, that app will not work for Android 6 (maybe that’s ok)

Plus, with minSdkVersion 24 error didn’t appear