"Any" in OAuth Allow list doesn't work

I want to use zoom application with multiple environments. There is info that I can use “any” for this: https://developers.zoom.us/docs/integrations/oauth/#using-multiple-environments. I added “any” as subdomain in redirect url in OAuth allow list section of zoom application settings. After that I try to execute next request: Error - Zoom
But I ge error: Invalid redirect: https://any.example.com (4,700)
What’s wrong?

Hello @kate.shutova wildcards cannot be used in our environment. Sorry about that

Regards, Kwaku

1 Like

Hello @kwaku.nyante! In such case why there is info that I can use “any”? https://developers.zoom.us/docs/integrations/oauth/#using-multiple-environments

Hi @kate.shutova
Jumping on this thread to add some extra information.
You are correct you can use “any” to support multiple domains.
Make sure to add the URI for your development and production redirect URL and also make sure to add it to your allow list.

1 Like

I did this, but it doesn’t work.
I added to the section OAuth allow listAdd allow lists of my zoom app settings next redirect url https://any.example.com
and I use this link:
but I get this error: Invalid redirect: https://sub1.example.com (4,700)
What can be wrong?
@elisa.zoom @kwaku.nyante

Hi @kate.shutova

Thanks for your patience here.
I have sent you a Direct Message with some follow up details :slight_smile:

@elisa.zoom I checked that “any” doesn’t work for published app too, maybe there are other reasons why “any” doesn’t work for me?

This topic was automatically closed after 30 days. New replies are no longer allowed.