Invalid Redirect URL (4700) on valid redirect url - OAuth redirect allow list is ignored

Description
When a user tries to authorize our Account-level OAuth app, they encounter following error message:

Error

{"status":false,"errorCode":4700,"errorMessage":"Invalid redirect: https://fakecompany.interpretmanager.com/app/zoom-oauth-account","result":null}

This worked before, no changes were made recently. We have this domain added to the OAuth allow list with any wildcard:

https://any.interpretmanager.com

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Details
App URL:

https://zoom.us/oauth/authorize?response_type=code&client_id=uVjvx49lRhOLChaU63ygEA&redirect_uri=https://fakecompany.interpretmanager.com/app/zoom-oauth-account

If I change redirect_uri to the default uri configured in Redirect URL for OAuth section, it works just fine, no error is displayed:

https://zoom.us/oauth/authorize?response_type=code&client_id=uVjvx49lRhOLChaU63ygEA&redirect_uri=https://app.boostlingo.com/app/zoom-oauth-account

Can you please check what’s going on? Seems like OAuth allow list is ignored.

@elisa.zoom sorry I had to reopen this issue. The previous was Invalid Redirect URL (4700) on valid redirect url

You replied that redirect that works fine (app.boostlingo.com) has a different domain than the one configured with the any wildcard syntax in OAuth allow list (any.interpretmanager.com), but that’s the whole idea of OAuth allow lists - to allow different domains. Domains listed in OAuth allow list should work, but they don’t.

We also have the same OAuth redirect settings for another user-level Zoom Marketplace app, and redirects work fine there for both domains.

Both links work just fine even though different redirect domains are used.

Same settings don’t work for account-level app:

This configuration worked before and stopped working some time ago and we didn’t make any changes to the account-level marketplace app settings.

Also we have “Subdomain check” setting disabled.

So it seems like OAuth redirect whitelist is not working on Zoom side for account-level app.

Hey @bl_developer

Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
My question here is, are these apps published in the Marketplace already?
If they are and you added a new URL to your allow list, you will need to resubmit your app for update to see these changes reflected.

@elisa.zoom Yes these apps are published in the Marketplace already. They were originally published with these redirect URLs added and it worked from the beginning. But then allow list suddenly stopped working even though no changes were made, as I described in the ticket.

Interesting, could you please open up a ticket here: https://devsupport.zoom.us/hc/en-us

With a link to this thread and I will be happy to look into this with more detail. @bl_developer
Thanks,
Elisa

@elisa.zoom I created a ticket here in addition to this thread https://support.zoom.us/hc/en-us/requests/14402770

1 Like

Thanks @bl_developer
I will take it from there!