API Key generator broken

Hello, have another problem. I decided to test your API v2 without your Playground so i generated new access token related on my Api Credentials.

When i try to use it i get 124 Invalid access token. I thought the problem with my Api Key/Api Secret that i have already been using with API V1 so i clicked to generate new.

Regenerate Secret - works fine, i got new Api Secret.

Regenerate Access Token - does nothing. It sends POST AJAX on https://developer.zoom.us/wp-admin/admin-ajax.php, gets 200 empty response and shows me alert with text “undefined”.

Anyway i tried to generate new access_token on https://jwt.io/#debugger-io, i put new secret and kept old key, took new access_token, did request and still got 124 invalid access token.

What’s wrong with API v2?

Hi Sergey, 

Will have reported this issue to our Engineers and will get back to you as soon as we find the bug and a workaround.


Hi Sergey, 

Is this related to the v2/accounts API? 

I guess this is related to whole API system.

This post is about broken API methods (https://support.zoom.us/hc/en-us/community/posts/360025854792-Playground-V2-doesn-t-work?page=1#community_comment_360002628231)

And this post is about broken button on https://developer.zoom.us/me/#api

It’s impossible to regenerate access token. May be this occurred because this account is sub-account(with Admin role) and not Master account, but on API V1 this worked fine.

Hi Sergey,

Can you check the role management page for this role - Zoom for developers  and see if (read or write) is checked?


Yes, it is

Any updates?

Hi Sergey, 

Can you make sure that your account has Chat history enabled as well? That needs to be enabled since we have IM Chat APIs. 

Chat history is disabled, but question was about API Secret, not about IM Chat History Token. Or these tokens are related to each other? 


Those tokens are related to each other, as the IM Chat is apart of our APIs. Please enable the IM Chat history and try to generate a access token. Let me know if that works. 


Thank you, it works! But it would have been better if you had shown message instead of empty alert)

Is it possible to fix this so it does not require enabling IM Chat History?

I am unable to enable IM Chat History for security considerations.

1 Like

As a workaround, I wonder if it works to enable - get the API key - then disable.

1 Like

Unfortunately, that will not work. Our legal department will not allow us to enable IM chat as it enables it for everyone.

I was able to develop a PowerShell script to create the JWT Token, so all is good now.

1 Like