Approval type "0" Required meeting overridden by some accounts

We’re able to make a meeting required via API by setting the approval type required to “0” when creating a meeting, but on some accounts it isn’t sticking.

Is there a setting on these accounts that is over-ridding it?

Thanks!

Hi @fred,

Are those users basic users ? If yes, you cant create a meeting that requires registration. This is the reason, the API returns, “approval_Type:2”. If you want to continue using the API, please upgrade your account to a PRO or higher level. You can visit here to know more about zoom plans.

Let me know if you have any questions.

Thanks,

I think the client is Pro. We can set the flag to Required meeting manually in the meeting.

@fred can you provide me with the complete request that you are sending?

Hi @Ojus,

I work with @fred. We are POSTing this payload to https://zoom.us/v2/users/me/meetings

{
“topic”: “Abs\/Core”,
“type”: 2,
“start_time”: “2020-04-04T14:00:00Z”,
“duration”: 30,
“timezone”: “EST”,
“agenda”: “44356”,
“password”: “6fI7cxX5I5”,
“settings”: {
“host_video”: true,
“approval_type”: 0,
“contact_name”: “XXXX YYYY”,
“registrants_email_notification”: true
}
}

Hi @RobertYeager

Here is the exact request body provided by you:

Here is the response:

,

To troubleshoot this further, can you please provide me with the userIDs with unexpected behavior? If you do not want to share the details here, can you please email them to us at developersupport@zoom.us?

Hi @Ojus,

Here is the response we received, converted to XML:

    <o>
        <agenda>44356</agenda>
        <created_at>2020-03-27T17:17:16Z</created_at>
        <duration>30</duration>
        <encrypted_password>XXXXXXXXX</encrypted_password>
        <h323_password>XXXXXXX</h323_password>
        <host_id>XXXXXXX</host_id>
        <id>909966990</id>
        <join_url>https://zoom.us/j/6707422731?pwd=XXXXXXXXXX</join_url>
        <password>XXXXXXXX</password>
        <pmi>XXXXXXXXX</pmi>
        <pstn_password>XXXXXXXXXX</pstn_password>
        <settings>
            <alternative_hosts/>
            <approval_type>2</approval_type>
            <audio>both</audio>
            <auto_recording>none</auto_recording>
            <close_registration>false</close_registration>

The approval_type returned to us was 2, not zero.

Sorry, I don’t know the UserID. Maybe @fred does.

@RobertYeager,

In the meantime, can you please visit: https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate#send-a-test-request , and send the same request body for the same user and see if you are receiving similar results?

Thanks,
Ojus

@Ojus

I did that using the OAuth access token for the customer’s connected account and the API returned a “2” for approval type:

@Ojus the URL we send contains “me”, I think that is what you meant by user id, right?

Hi @RobertYeager,

It seems the user is using his PMI to schedule meetings, which is why it is reverting to the default settings.

Disabling this option from the users profile should resolve the issue (visit https://zoom.us/profile/setting):

Thanks,
Ojus

1 Like

Thanks @Ojus!

Very helpful :slight_smile:

1 Like

Thanks Ojus! :slight_smile:

-Tommy