Black screen when joining call with custom UI enabled using Android SDK

When starting an instant meeting with the custom UI option enabled, everything works fine. Figured out the config.xml, I do start my own Activity that extends MeetingActivity based on the samples provided (example2). I do not want to change the Zoom UI a lot, I just want to add a toolbar basically and have the floating window enabled when the activity is “minimized”, so no need to go fully custom. I included in my Activity layout the “@layout/zm_conf_main_screen”.

So when I start an Instant Meeting, everything works as expected without any issues (logged in user), but when I try to join this meeting (Anonymous user) I just get a black screen, but the call is ongoing and I see myself on my other device (call host). I tried using not my implementation but the sample in “example2” and the same problem there persists, however, when I run the “sample” in the sample project with Custom UI enabled and an Anonymous user (same scenario just fully custom view), then everything works fine.

Tested on different phones, same issue. When host all is good.

Which version?

To Reproduce(If applicable)
Steps to reproduce the behavior:
In “example2”
Be anonymous

  1. turn on custom ui in meetingsettingshelper (in code and in onInitialized callback)
  2. make it join meeting and NOT start meeting
  3. Add manual startActivity on meetingStatus == MeetingStatus.MEETING_STATUS_CONNECTING
  4. Join to a hosted instant meeting with custom ui enabled

Hi @Jorje,

Thanks for using Zoom SDK. If you are referring to the implementation in example2, that is not using Custom UI(It’s embedding a Zoom default UI in a view) so you do not need to turn on setCustomizedMeetingUIEnabled(true) .

Hope this helps. Thanks!

Thanks for answering. The problem arises when I want to show a floating video view when MyMeetingActivity closes and I guess I have to have custom UI enabled or else I get an NPE (there is a check somewhere, I think when retrieving the default video view manager) so I have to enable custom ui

Hi @Jorje,

Thanks for the reply. It seems like you are mixing up Zoom default UI and Custom UI and this will not work. If you would like to show floating video view, you will need to use the full Custom UI mode.