BUG: Creating a scheduled meeting with `join_before_host` does not allow joining before host

According to https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate one is able to enable join_before_host on scheduled on reocurring meetings. However on setting this and attempting to join from an unauthed user or a user from a different account, one is greeted by `waiting for host.

The returned meeting does have the join_before_host setting set to true, which is the even weirder part.

See above

Which Endpoint/s?
See above with a jwt app.

How To Reproduce (If applicable)

  1. Use endpoint above, set join_before_host to true and meeting type to 2 (scheduled meeting)
  2. Set time to a minute in the future utc.
  3. Receive a 201 response with join_before_host clearly set to true
  4. Try to join as someone else and be sad :frowning:

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Ok, thanks to some wonderful help from my coworker and lot’s of trial and error. We discovered there was a waiting room setting implicitly added to the meeting.

I do not recall that being the case a year ago, but I might be misremembering!

Looks like this is not a bug, it still might be worth updating the documentation to let user’s know the waiting room setting defaults to true and the join_before_host setting is overridden by that one.

1 Like

Hey @matt,

Happy to hear you got this sorted out. We’ll look into updating our documentation to try and make things a bit clearer, but appreciate your raising this with us! Another reason this could’ve happened is that ‘join_before_host’ and waiting room settings could’ve been turned on at the account level, meaning unless join_before_host is explicitly stated in your API request, it will default to account-wide settings.

cc @shrijana.g


1 Like

@matt @will.zoom Thank you for letting me know about this issue. The waiting room setting does override the join before host setting. I have updated the doc to reflect this.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.