Bug in API documentation? "Get User"

Format Your New Topic as Follows:

API Endpoint(s) and/or Zoom API Event(s)
Link the API endpoint(s) and/orZoom API Event(s) you’re working with to help give context.
https://api.zoom.us/v2/accounts/{accountId}/users/{userId}

Description
“Get Users” is incorrect in the documentation?

Error?
The full error message or issue you are running into, where applicable.
Invalid access token - error 124

As described in the documentation, the documented path is listed as: https://api.zoom.us/accounts/{accountId}/users/{userId}

How To Reproduce
Steps to reproduce the behavior:
1. Request URL / Headers: /accounts/{accountID}/users/{userId}
2. Authentication method or app type: Server to Server OAUTH
3. Any errors: Invalid Token Error 124

This has been bugging (hah!) all night, I kept getting the invalid token, yet other calls to the API worked with the same Bearer token.

It wasn’t until I removed the /accounts/{accountID} from the URL that the “get user” API started working.

Effectively, this is what worked for me: https://api.zoom.us/v2/users/{userID} [with the necessary token information passed in the headers]

I think the documentation needs to be updated to reflect the correct usages (or the api to be updated to reflect the documentation).

Thanks!

Hi @ericp , that prepended part of the endpoint is for Master Account APIs. If you do not have this account structure, that could explain failure. Please clarify if this is the case :slight_smile:

Yup, that was the issue :flushed:

I’m not sure how I got into the Master Account APIs section of the site, but that was the cause of my issue . Thanks for setting me straight!

All good! Glad it’s resolved!