Can not create the meeting

Description
it worked fine 2weeks ago, but it is not working with same code

it is possible to join meeting but it fails when i create a meeting.

Which version?
v4.6.21666.0428

NSData *resultData = [NSURLConnection sendSynchronousRequest:mRequest returningResponse: **nil** error: **nil** ];

NSDictionary *dictionary = [NSJSONSerialization JSONObjectWithData:resultData options:NSJSONReadingAllowFragments error: **nil** ];

dictionary returns below message

Printing description of dictionary:
{
    code = 124;
    message = "The Token's Signature resulted invalid when verified using the Algorithm: HmacSHA256";
}

Hi @taehunchoi,

Thanks for the post. Could you provide more information or context regarding what you are trying to do here? Are you sending a request to Zoom REST API using JWT token to create a meeting? Is the JWT token expired?

Thanks!

i’m trying to make a meeting room from iOS app.

i worked exactly fine 2 weeks ago.
So i assumed that TOKEN might be expired.

i renewed api secret and tested it again. but i got same result.

Hi @taehunchoi,

Are you creating a meeting by sending a request to https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate?

If you are able to join a meeting in SDK, that means your SDK key & secret is working well. If you failed to create a meeting using Zoom API, then the issue might be related to the API key & secret or the JWT token. Are you able to use other RESTful API in https://marketplace.zoom.us/docs/api-reference/introduction? If not, then your API key & secret might have some issues.

Thanks!

Hi Carson

i am able to join a meeting with SDK key, but not able to create a meeting with API Key.
So i renewed API secret but i got same result.

i will try with other restful api today.

thanks

Hi @taehunchoi,

Thanks for the reply. It seems like the issue you are facing is with API credentials and the Zoom API now. Let me forward your question to the API section and have the API experts to further help you.

Thanks!

is there any solution?

the problem happens below function.

when the “access_token” is token then dictionary returns nil
but if the “access_token” is zak then the dictionary returns value

  • (NSString*)requestTokenOrZAKWithType:(MobileRTCSampleTokenType)type withKey : (NSString *) key withSecret:(NSString *) secret withUserEmail:(NSString *) userEmail {
    NSString * bodyString = [NSString stringWithFormat:@“token?type=%@&access_token=%@”,type==MobileRTCSampleTokenType_Token?@“token”:@“zak”, [self createJWTAccessToken:key withSecret:secret]];
    NSString * urlString = [NSString stringWithFormat:@"%@/%@/%@",@“https://api.zoom.us/v2/users”,userEmail,bodyString];
    urlString = [urlString stringByAddingPercentEncodingWithAllowedCharacters:[NSCharacterSet URLQueryAllowedCharacterSet]];
    NSLog(@“urlString = %@”,urlString);

    NSURL *url = [NSURL URLWithString:urlString];
    NSMutableURLRequest *mRequest = [NSMutableURLRequest requestWithURL:url cachePolicy:NSURLRequestUseProtocolCachePolicy timeoutInterval:60];
    [mRequest setHTTPMethod:@“GET”];

    NSData *resultData = [NSURLConnection sendSynchronousRequest:mRequest returningResponse:nil error:nil];
    NSDictionary *dictionary = [NSJSONSerialization JSONObjectWithData:resultData options:NSJSONReadingAllowFragments error:nil];

    return [dictionary objectForKey:@“token”];
    }

Hey @taehunchoi,

If the user has used user name and password to create their Zoom account, then getting a users token via the token query param will return nil. This means the user created their Zoom account using Google or another SSO service.

Thanks,
Tommy