Can't join meetting


#1

I change the kSDKAppKey and kSDKAppSecret. Run the sample, show the error code : 2.


#2

Hi 82860542,

Thanks for using Zoom SDK. The error code indicates your SDK key or secret is invalid. Can you confirm your key and secret? Or can you provide more information on how you get this error?

You can also refer to our doc to double check if there is anything missing in the code: https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/getting-started/edit-key-and-name

Thanks!


#3

I download the sample again, version is v4.3.30728.0118. I enter the same key & secret, it’s ok now. But I want to join meeting, show this " 2019-03-07 12:40:17.918419+0800 MobileRTCSample[20453:6450402] onJoinaMeeting ret:150",than can’t push the meeting page.


#4

I built a new project according to the document. I want to join meeting from the other phone that download zoom from appstore. Xcode show this onJoinMeeting, response: 150.can’t puch the meeting page.If I have to add some delegate method?


#5

Hi,
Error code: 150(https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/resource/error-codes#14-meeting-error-codes) means you pass invalid arguments to join a meeting. Please double check the arguments you pass to join a meeting. The display name(kSDKUserName) and the meeting number are required and they cannot be empty.


#7

Hi,
sample and my project had entered the kSDKUserName.


#8

I had entered kSDKUserName, kSDKAppKey, kSDKAppSecret,but I can’t join the meeting. Error code:150.Are there any other parameters I need to input?


#9

Hi, if you have successfully initialized the Zoom SDK with valid SDK key and SDK secret, then you should be able to join a meeting with valid meeting number and valid username. These are the required parameters, other parameters are optional. I tried to reproduce your issue by using the code snippet shown in your screenshot. If you try to call the join meeting function inside the method that you bind with the join meeting button, you will not be able to join the meeting. If you write another function to get the meeting info from the view, with the same codes, you will be able to join a meeting. Hope this helps.

Let me know if you have any other questions.Thanks!


#11

How can I get the meeting info? And Why the sample is the same mistake? My SDK info went wrong?
I’m sorry to have to bother you, but I am now very need help, thank you!!


#12

Hi,
It depends on how you collect the meeting info. Take our iOS SDK demo as an example, the demo is using an alert view to collect meeting info(meeting number and meeting password), then in MainViewController.m, you will find the method:

- (void)alertView:(UIAlertView *)alertView clickedButtonAtIndex:(NSInteger)buttonIndex
{
    if (buttonIndex != alertView.cancelButtonIndex)
    {
        NSString *meetingNo = [alertView textFieldAtIndex:0].text;
        NSString *meetingPwd = [alertView textFieldAtIndex:1].text;
        
        [self joinMeeting:meetingNo withPassword:meetingPwd];
    }
}

Collect the meeting info and then pass them to join meeting function would allow you to join a meeting. If you are collecting the meeting info using other methods(like Text Field), you can implement a related method to achieve this.

Suggestion:

  1. Don’t bind join meeting function with the button
  2. Choose a way to collect meeting info (text field, alert, etc.)
  3. Get the meeting info, pass to the join meeting function to join a meeting

Cheers!


#14

I am using an alert view to collect meeting info,but it still show error code 150. I try to copy the example code, the same result. And the sample I had enter kSDKUserName , kSDKAppKey , kSDKAppSecret ,it also show code 150.


#15

Hi,
Based on the info you provided, it’s unfortunate that the root cause was not able to identify at this point. As I have mentioned before, the error code 150 means “Invalid arguments”. Here is a checklist that could possibly help you to troubleshoot this issue, I understand you already did some of them, but please go over them one-by-one:

  1. Do you have SDK key & secret that is generated from https://marketplace.zoom.us and activated? — [Yes: Please see next question]/[No: Please visit marketplace.zoom.us to generate a pair of SDK key & secret, and then activate it]
  2. Were you able to download the Zoom iOS SDK demo and set the following constants in AppDelegate.h like the following? (kSDKAppKey to be your SDK key, kSDKAppSecret to be your SDK secret, kSDKDomain to be zoom.us) — [Yes: Please see next question]/[No: Please set the above fields to be the relevant info]
  3. Connect your iOS device, are you able to build and run the app on your device? — [Yes: Please see next question]/[No: Please see the console log and locate the error]
  4. When in the demo, press “Join Meeting”, enter a valid meeting number that is pre-scheduled or your PMI(Personal Meeting ID), are you able to join the meeting? – [Yes: Please see next question]/[No: Please try to schedule a meeting before using or use your PMI. If the error code 150 issue still exist, please provide more log to help us troubleshoot the issue]
  5. If the demo app works fine, then switch to your own app: If you mimic the way that our demo does to 1. create an alert 2. get meeting info from alert view, then pass to join meeting function, does it work? – [Yes:Everything looks good]/[No: Please try to troubleshoot the code by doing multiple unit tests, make sure the meeting info(meeting number, display name, etc.) are collected as expected, and the relevant methods are being called properly]

Hope this check list helps. And please let us know if you have any other questions or found the root cause.

Cheers!


#16

It can run now. The reason is that I didn’t enter the kSDKDomain, I didn’t find it from the documentation to enter zoom.us. I tried typing other text, but I was prompted with error code 5, so I didn’t enter this again.
Thank you very much for your help.


#17

Hi,

Glad to hear that it is working now. We will keep improving our documentation to make it more clear. Thank you again for using Zoom SDK. :slight_smile:

Thanks!