Cant record video using meeting sdk

follow the steps in this github

error screenshot -
zoomsdk-build | :white_check_mark: configure
zoomsdk-build | :white_check_mark: initialize
zoomsdk-build | :white_check_mark: authorize
zoomsdk-build | :white_check_mark: join a meeting
zoomsdk-build | :hourglass_flowing_sand: connecting to the meeting
zoomsdk-build | :x: unknown meeting status
zoomsdk-build | :hourglass_flowing_sand: reconnecting to the meeting
zoomsdk-build | :hourglass_flowing_sand: connecting to the meeting
zoomsdk-build | :white_check_mark: connected
zoomsdk-build | :hourglass_flowing_sand: requesting local recording privilege
zoomsdk-build | :white_check_mark: start raw recording
zoomsdk-build | :white_check_mark: create raw video renderer
zoomsdk-build | :white_check_mark: subscribe to raw video

after this, i am not receiving any video recording, although the recording has started in my meeting

any idea why is this happening?

code responsible for video rendering -
if (m_config.useRawVideo()) {
if (!m_videoSource) {
err = createRenderer(&m_videoHelper, m_videoSource);
if (hasError(err, “create raw video renderer”))
return err;
auto participantCtl = m_meetingService->GetMeetingParticipantsController();
int uid = participantCtl->GetParticipantsList()->GetItem(0);
err = m_videoHelper->subscribe(uid, RAW_DATA_TYPE_VIDEO);
if (hasError(err, “subscribe to raw video”))
return err;

@chunsiong.zoom can you look into this issue

@nandakishor2010608 do you have a sample of the SDK Auth token which you were using?

Please tag me in your reply


@nandakishor2010608 ,

Did the bot successfully joined the meeting? And did you provide it with recording permissions?

yes, it joins the meeting properly, and im giving recording permission as well. Iam able to get the audio now but video data is not coming through


@nandakishor2010608 is the flag to record raw video turned on in config.txt?

I have the same issue, what is the flag to record raw video?

i added to config.ini, and it did not work


@MaxM need your help on this for a bit

yes the flag has been set



Thank you for bringing this to my attention! I was able to reproduce the issue and am working to release a fix.

@MaxM thank you for spending time on this, looking forward to the release

Hey fixed the issue, so the reason for this issue was i was trying toi record the video of the bot but the bot has no video, changed the uid passed in the subscribe() method and it works now. Thanks
@chunsiong.zoom @MaxM

1 Like

It looks like there were also some code issues on my end. I’ve been able to push out a fix and will close this thread now. Thanks for sharing what worked for you!