Changing the scheduled host for an existing meeting

Getting same error while update meeting using PATCH method to change Existing host to New Host,

{“code”:3000,“message”:“You cannot schedule a meeting for .xx-user-id-xx.”}

If you are not allowing to change hosting for existing created meeting using field “schedule_for” field then why field schedule_for has been given for updation request ?

It very confusing that field is given to change host for existing meeting and its not working properly.

Its giving same error for licensed users and free users. Not working at all.

Why there is concept of user/host/email address in Zoom architecture for creation of meeting.?

Simply allow to create as many meetings but allow to start no of meetings which are Licensed / or as Per Configuration.

Just like other meeting provider, will simple create meetings allow to start or join (Gmail, Jitsi, and Others many more)

Why to create meeting inside perticular host /user ? just allow to create meeting directly

In this below link, it has been specified

Scheduling privilege

Overview Scheduling privilege is designed for a user or an executive admin to: You can assign or delegate a user or multiple users in your account to schedule meetings on your behalf. You can als…

But where to specify which user is creating/update scheduel meeting on behalf of which user (how to specify both ? ) ?

Hi @brijeshnp ,

You can set the role permissions for a user by following the steps in this article:

Once you’ve set those role permissions, you can assign users to that role via API with this endpoint:

This article also outlines the prerequisites for assigning alternative hosts:

Thank you,

Is possible to use set scheduling rights by admin api(or some other api) of particular user to second user without using zoom web console.

If yes. How to implement that api (or give name of that api) it using admin rights via JWT Token ?

Yes @brijeshnp you can:

Hope this helps!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.