API Error: PATCH Meeting - change a host of a meeting by calling API with an error

Hi there! how to change a host of a meeting by calling API?

I have tried calling PATCH# /meetings/{meetingId} with “schedule_for: {user_id}” in the request body, but it showed me the error below.

“code”: 1110,
“message”: “Not assigned scheduler.”

**Which App Type: OAuth and JWT both

I used a business-level account which has 10 licensed user under it.

Hey @joy.guan,

Please see the requirements and instructions of the schedule_for feature here:


Thanks Tommy :slight_smile:

1 Like

Happy to help @joy.guan!

Let me know if you have additional questions! :slight_smile:


Hello, I am running into the exact same issue. I am using JWT, so I do not believe this is anyone to set the Scheduling Priveleges for as you suggest. Can you offer any other advice?

We only started noticing this error a few weeks ago. Prior to that it worked like a charm. Any help very much appreciated!


Hi @christian.delaune the JWT app will not have scheduling permission assigned to it; rather, the userID of the original host will need to have scheduling privilege assigned to them for the other userID you want to transfer the meeting to.

Just tested it out and that did the trick. Thanks so much for the quick response!

Great @christian.delaune, let us know if we can help on anything else!