Create Meeting API with breakout_room settings does not enable the breakout rooms

Hello,
We’re trying to create an instant meeting using the Zoom API /users/{userId}/meetings with breakout room settings in the payload. The payload we’re sending for this instant meeting is:

{
  topic: 't',
  agenda: 't',
  type: 1,
  settings: {
    host_video: false,
    participant_video: false,
    breakout_room: { 
      enable: true, 
      rooms: [
        {
          name: 'Breakout Room 1',
          participants: [ '***@gmail.com' ]
        },
        {
          name: 'Breakout Room 2',
          participants: [ '***@gmail.com' ]
        }
      ]
    }
  }
}

Please note:

  • Our account subscription plan is Business
  • Breakout rooms option from the https://zoom.us/profile/setting has been enabled, along with all the suboptions under it.
  • The API call is made on our Node.js server and the information is returned to our Client view UI that is using the Web Meeting SDK to join the meeting.

But after the meeting is created, upon checking the payload we see that the settings.breakout_room.enable is set to false, and no rooms array is returned in that object. We have followed other posts in the forum but haven’t found a solution to this yet.

{
  uuid: 'Dxzlx0j******9f5ft28TA==',
  id: **************,
  host_id: '****************',
  host_email: '***********@gmail.com',
  topic: 't',
  type: 1,
  status: 'waiting',
  timezone: 'America/Los_Angeles',
  agenda: 't',
  ...
  settings: {
    host_video: false,
    participant_video: false,
    join_before_host: false,
    use_pmi: false,
    approval_type: 2,
    audio: 'both',
    enforce_login: false,
    enforce_login_domains: '',
    alternative_hosts: '',
    alternative_host_update_polls: false,
    close_registration: false,
    show_share_button: false,
    allow_multiple_devices: false,
    waiting_room: true,
    meeting_authentication: false,
    encryption_type: 'enhanced_encryption',
    **breakout_room**: { enable: false },
    alternative_hosts_email_notification: true,
    device_testing: false,
    focus_mode: false,
    enable_dedicated_group_chat: false,
    private_meeting: false
    ...
  },
  pre_schedule: false
}

Can you please help us debug if there’s something wrong with our configuration? Thanks in advance.

I have the same issue, getting false for breakout rooms any solution to this ?

Is there a solution to this ridiculous problem? Why is this API so hard to work with?!?!? I just wanna create a meeting with the desired settings. Nothing seems to work to solve this.

Any updated on Breakout-Rooms-API and the ability to dynamically create rooms and assign users without the need to import a CSV file.

This is all I see so far…

Good morning, I would like to know if this option to start break rooms through Zoom API is already operational.

Greetings.

I have never received a response from Zoom for the missing API calls.