Create meeting setting `waiting_room: false` doesn't work

I’m creating a meeting with POST https://api.zoom.us/v2/users/me/meetings

Since the introduction of waiting rooms, my join_before_host setting began to be ignored. I saw the new param waiting_room, but setting it false doesn’t seem to work.

Request body:
{"settings":{"waiting_room":false,"join_before_host":true,"use_pmi":false},"topic":"blah","duration":30}

The response has "waiting_room": true and sure enough, the meeting has a waiting room and requires the host to be in it.

  1. What am I doing wrong?
  2. How can I be notified of upcoming breaking changes like this in the future?

Hey @mike8,

This change was made a few months ago when we decided to enforce having either a Passcode and or Waiting Room turned on for meetings.

Please ensure you are setting a passcode for your meeting, then you will be able to turn off the waiting room.

You can also check your account level settings to see if the waiting room setting is locked to on.

This change was sent to every email with a Zoom account, you can reach out to support.zoom.us if you were not notified.

Thanks,
Tommy

Thanks, Tommy! Very helpful. I see in the API docs that I have to generate a password myself, there’s no option to make Zoom generate one?

Hey @mike8,

Depending on which scenario your API request falls under, you may be able to pass an empty string in order to have the API autogenerate a password for you.

Best,
Will