Demo SDK Application error Type: LastErrorType_auth, code:10124

Meetting SDK type and version



Follow these instructions: Meetting SDK - Windows - Get Started
Use Visual Studio 2022 to build with “Release x64” configuration
Copied the JWT from the credentials page for my app

@chunsiong.zoom Please help me just fix this

@tien01nx ,

For a start, the JWT token needs some fixing. I’m assuming you did some photoshop / edits so it is truncated. But I’ll still mention it here.

  1. meeting number needs to be valid
  2. appKey instead of app_key
  3. appKey and sdkKey should be the same value.

You can choose to either use these pair

  • SDK Key + SDK Secret (If you are using this, appKey & sdkKey is SDK Key)
  • Client ID + Client Secret (If you are using this, appKey & sdkKey is Client ID)
  1. exp and tokenExp should be identical value, and must be at least 1800 seconds greater than iat, and not longer than 48 hours from iat.



appKey and sdkKey value : Secret Token


@tien01nx , this might be the wrong credentials
You will need Meeting SDK App type and use the Client ID and Client Secret found here

and your exp and tokenExp needs to be the same value

I chose exp and tokenExp to be of equal value
“appKey”: Client ID
“sdkKey”: Client Secret
Still have the same error


@tien01nx please do one thing here

“appKey”: Client ID
“sdkKey”: Client ID

I chose exp and tokenExp to be of equal value
“appKey”: Client ID
“sdkKey”: Client ID

Still have the same error

@tien01nx , is the meetingNumber entered with a valid meetingNumber?

I know you entered 10 (which is not a valid meeting number)

So which number will be valid?
Please tell me more content meetingNumber ?

@tien01nx , it has to be the Zoom Meeting number which you want the SDK to join.

Example when you are scheduling a meeting, there is a meeting number which will be generated, you need to put the meeting number into the JWT token

According to you, it is this number

it still has the same error as above

@tien01nx , could you make sure that Meeting SDK is turned on?

I still had it on from before


I did as you said but the error still occurs

I’ll private message you

1 Like

Resolved: Issue with JWT creation which cases invalid JWT Token error. Once the JWT is generated according to specifications, the SDK is able to authenticate successfully.