Disable screen recording in zoom

I checked other threads and added the following code in my custom meet activity
window.setFlags( WindowManager.LayoutParams.FLAG_SECURE, WindowManager.LayoutParams.FLAG_SECURE )
In emulator and mobiles like samsung, screen recording is getting disabled. But in chinese mobiles like xiaomi, vivo, one plus, users can able to record screen.

Which Client Android SDK version?

Steps to reproduce the behavior:

  1. Join a meeting
  2. Start screen recording using az screen recorder

Additional context
I added zm_config_conf_activity in config.xml and made sure my custom meet activity is getting executed.
I even added logs above window.setFlags( WindowManager.LayoutParams.FLAG_SECURE, WindowManager.LayoutParams.FLAG_SECURE ) this code, it is getting but screen is still getting recorded.

Please provide a default option to disable screen recording

Hi @testpress, thanks for using our SDK.

Can you please clarify whether you’re trying to disable screen sharing in a meeting or prevent only certain views from being shared when you are already screen sharing?


I am trying to disable screen sharing in meeting.

Hi @testpress, thanks for confirming.

There are two options for disabling screen sharing: programmatically through the SDK or by modifying the meeting settings.

To do so programmatically, you can use the lockShare method.

You can also modify the Screen sharing setting under your settings profile to disable screen sharing.


Hi, I meant Screen recording not screen sharing. We don’t want users to record the meeting using some third party recorders and share it to others.

Hi @testpress,

Thank you for clarifying. The Android SDK does not directly support anything to prevent users from recording the contents of their screen while in a meeting. There may be some security options available for this in the Android framework, however that would be outside of the scope of what we are able to assist with on this forum. I recommend checking out the official Android documentation to investigate that approach.


yes same problem with me.

Hi @lj799877,

Have you taken a look at the information referenced in my previous reply? Please let me know if there’s anything else I can help with.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.