DLL gets Load Module Error when attempting to initialize

I am building a dll that includes the Zoom Video SDK.
I am following the directions here: Video SDK - Windows - Integrate

Which Windows Video SDK version?

To Reproduce(If applicable)
m_pVideoSDK = CreateZoomVideoSDKObj(); // works
int returnVal = m_pVideoSDK->initialize(initParams); // fails

The returned value is ‘ZoomVideoSDKErrors_Load_Module_Error’ (defined in zoom_video_sdk_def.h)

Troubleshooting Routes
Every file in the build directory and every file in /bin and /lib from the sdk has been copied into the same folder as my dll. (This includes not just .dll and .lib files, but also zCrashReport64.exe, etc.)
The demo app does build & run, so I have tried copying in all of the files adjacent to the built exe, just in case something was missing.
Used DependenciesGUI to confirm that all declared direct and indirect dependencies of the dll were found.

Device (please complete the following information):

  • Device: MSI GS63 Stealth
  • OS: Windows 10

Further testing:
(1) Built a simple console app and copied my dll, and all of its dependencies.
(2) Execution of the console app succeeded!
My guess is that the IDE that is using my dll (and all of its dependencies) is not being diligent about how it packages everything…

SOLVED: Flushed out all of the old files & reimported… now it works.
IDE must have been “stuck in a bad state” where the compile & run for testing was not actually copying everything that it should!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.