Email notification doesn't come to the host when creating meeting

As written in the title, I find that when creating a meeting from zoom API, the host does not get any email notification even if the “registrants_email_notification” is set to “true”. I have noticed that this issue is being reported as a bug, is there any follow ups? Or is it simply the host won’t get email notifications?

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create a meeting from API
  2. No email notification

Screenshots (If applicable)
“topic”: “test”,
“type”: “2”,
“start_time”: “2021-06-07T11:22:33.857Z”,
“duration”: 60,
“timezone”: “Asia/Tokyo”,
“password”: “password”,
“agenda”: “Agenda”,
“settings”: {
“registrants_email_notification”: true

Additional context

Hi @kouicademo,

Thank you for reaching out about this, and happy to help. First, I should note that the bug you referenced in the linked threads should have been resolved, so I believe this is likely not related.

However, to confirm—are you referring to the host not receiving an email when a meeting is scheduled, or a host not receiving a registration confirmation email? Note that if it’s the ladder, hosts won’t receive a registration confirmation email.

If it’s the former, can you please ensure that your account level email settings are enabled? It’s possible this could be overriding your API requests (Account Management > Account Settings > Email Notifications):

Let me know—thanks!

Hi @will.zoom

Thank you for your quick response, and I appreciate your help.

My apologies for the confusion, I was talking about the host not receiving an email when a meeting is scheduled. Since I have only been working with the zoom API for a short period of time, I am having trouble finding the “Account Management” setting you mentioned. Could you please provide some detailed information on where to find this setting? Thanks!


Hi @kouicademo,

Thanks for clarifying! In order to view the Account Management page, you’ll need to be either an Admin or Owner of the account. If you are, you can access it by navigating to this page when logged in:

Let me know if this helps!

Hi @will.zoom

Thank you for your help! According to my “Account Profile” page, I am the Owner of my account. And I am also the Admin user of the account in the App Market. But when I tried to access the URL you provided, it shows “No permission. (200)”. I’m wondering why is that.
Thank you.


Hi @kouicademo,

Are you on a free/basic account? This could be the cause.

If you’re on a paid account and are seeing this error, I will recommend reaching out to our Support Team directly here to assist with this, as they’re the experts in this domain.


Hi @will.zoom

Thank you for your help. Yes, I am on the free account.
Thanks for the explanation.


1 Like

Hey @kouicademo,

I’m glad to hear that Will was able to help! I’ll go ahead and close this topic now but feel free to open a new topic if you encounter any further issues or questions.