ERR_OSSL_EVP_UNSUPPORTED when running the react meeting SDK sample

Trying to get the react meetingsdk sample repo working, but it seems to have lots of issues. Ignoring the numerous vulnerabilities after npm install, having followed the steps provided in the documentation, and making no other changes, at step 6) npm start - I get the following error message:
opensslErrorStack: [ ‘error:03000086:digital envelope routines::initialization error’ ],
library: ‘digital envelope routines’,
reason: ‘unsupported’,

This issue is consistent across multiple computers, by simply cloning the repo and following its instructions to perform the basics (install, populate fields with your unique sdk key, then running npm start).

I’ve tried changing node versions (downgrading to LTS), using node option openssl legacy provider open ssl legacy provider and other options, but have not found a work around or solution.

Any help would be greatly appreciated.

For anyone that stumbles on this thread:

Finally resolved this issue. It was related to openssl-legacy-provider, and the solution was a modified version from this stack overflow thread

essentially, was using windows so tried the top answer, changing package.json scripts to:

"scripts": {
    "start": "set SET NODE_OPTIONS=--openssl-legacy-provider && react-scripts start",
    "build": "set SET NODE_OPTIONS=--openssl-legacy-provider && react-scripts build"

However, “set SET NODE_OPTIONS…” did not work, instead tweaking this to:

"scripts": {
    "start": "SET NODE_OPTIONS=--openssl-legacy-provider && react-scripts start",
    "build": "SET NODE_OPTIONS=--openssl-legacy-provider && react-scripts build"

Resolved the issues.

The meetingsdk had some further issues to overcome, such as ‘No version of chokidar available’ ( solution here )