Issues with the React Meeting SDK sample

React Meeting SDK version 2.16.0

Running into issues trying to get the React Meeting SDK Sample to work.
On npm install meeting sdk has 30 vulnerabilities. in this case they include breaking changes if you try and run an audit fix, but for many repos you can safely ignore these warnings if they’ve been bootrapped from create react app.

The main issue occurs when trying to run ‘npm start’. When executing this command you get the following error message:

opensslErrorStack: [ ‘error:03000086:digital envelope routines::initialization error’ ],
library: ‘digital envelope routines’,
reason: ‘unsupported’,

Image of error

Troubleshooting Routes
Have tried downgrading node version (from 20.5.1 to earlier versions 19.xx, 18.xx)
have tried running npm start with openssl legacy provider

How To Reproduce
Steps to reproduce the behavior including:
*1. Clone React Meeting SDK Repo (link above)
*2. follow steps 1-6 included in the readme

Hi @peterprinciple
Thanks for reaching out to us!
Allow me some time to try and run the sample app on my and and I will try to replicate this and will get back to you

Hi @peterprinciple
Thanks for your patience here.
I was able to replicate this on my end using the latest version of the app.
I got it working just by changing one of the scripts in my package.json

"scripts": {
    "start": "react-scripts --openssl-legacy-provider start",
    "build": "react-scripts --openssl-legacy-provider build"

I will report this issue internally in the meantime.
Hope this helps