Error code: 1107, Message: You can not disassociate a user with managed domain

API Endpoint(s) and/or Zoom API Event(s)
Attempting User Delete as per documentation:

My app is a server-to-server OAuth and is as account-level app.

I’m trying to delete users with the API call as described on the above documentation page (see my code below) but I get the below error:
“code”: 1107,
“message”: “You can not disassociate a user with managed domain.”

I do have SSO enabled with Zoom for my domain which I assume is what is meant by a ‘managed domain’.

  1. Is there a way to delete users through the API with managed domain (e.g. by turning off managed domain for that user first, or by passing in some authentication token from my domain to allow this)?
    I know I can go into Zoom admin portal and just click ‘delete’ on a user so I’m not certain what the trip-up is here.

  2. I note the error message says ‘disassociate’ even though I’m passing in the action of ‘delete’.
    So also very happy if I’m just passing in this action wrong.
    I’ve tested the below code for GET user info and it works well, the only new bit is the apiPayload where I’m adding the ‘delete’ action to the call.

Any help would be greatly appreciated.

How To Reproduce
//My code (Javasceript):

function fn_zoomDeleteUser() {

//testing only - remove for actual
var USER_EMAIL = ‘’

// get API token for making the below call
var token = service_ZoomAPIToken()

var url = ''+USER_EMAIL

var apiPayload = {
action: ‘delete’

var options = {
method: ‘DELETE’,
muteHttpExceptions: true,
headers: {
Authorization: 'Bearer '+ token // Do not publish or share this token publicly
payload: JSON.stringify(apiPayload)


var response = UrlFetchApp.fetch(url, options);
var result = JSON.parse(response.getContentText());

return result;


Hi @phil.l
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
So, it looks like you are passing the action delete in your request body
Could you please set this value in your query params and try again?

Amazing, thanks Elisa. That’s solved it!

1 Like