Error:invalid_client

Description
I’m trying to programmatically add attendees to webinars. I can’t get past the very first hurdle: requesting a user authorization token. I’ve been trying for days to do so using RestSharp, but I invariably get the same error:

Error
{“reason”:“Invalid client_id or client_secret”, “error”:“Invalid_client”}
Unauthorized

To say Zoom’s documentation is unhelpful would be unwarrantedly generous.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Which Endpoint/s?
https://zoom.us/oauth/authorize

Hi @mark.krawec,

Thanks for reaching out about this, and happy to help.

It sounds like you’ve already seen our guide for retrieving an access token, right?

If you’re still having trouble, a few things to double check:

  • You’ve successfully created an OAuth App to generate a Client ID and Client Secret
  • You’re grabbing the code parameter from the redirect URL after hitting the user installation URL (install button, testable URL)
  • You’re including the required Authorization header in your request

Once you’ve double checked these things, I also recommend checking out this thread:

Please let me know if this helps!

Best,
Will
*

Hi Will

Yes, I’ve been through the guide a few times. Sadly it hasn’t helped. I still haven’t been able to decipher how to request a token. I’ve also read the thread you linked, also repeatedly. Haven’t managed to glean anything useful from that either.

This is the first time I’ve tried to do anything with REST, let alone Zoom’s API, so it may be that there’s something I don’t understand on an even more fundamental level than the documentation here covers.

Tried again earlier this morning & am at least receiving a different error. Now it’s telling me “Invalid client_id:(4,700)” which is very odd because I copied that directly from the OAuth App (https://marketplace.zoom.us/develop/apps/9SMZLoWdT9u9Fn0n6BmLHA/credentials)

Hi @mark.krawec,

Thanks for checking those details out. In order to take a closer look, can you please send us an email at developersupport@zoom.us with the following details:

  • The email address or user ID of the OAuth App owner (the app you’re using to authenticate your requests)
  • The full request URL and authorization header you’re using when requesting an access token:

This will help me to take a closer look at your account and credentials to further debug.

Thanks!
Will

I think I’m getting an idea what the problem is here. At no point is the end user ever going to (or at least is ever intended to go to) https://zoom.us/oauth/authorize to receive an authorization code.

The idea behind what I’m doing is this: we’re using Zoom to enable remote participation in certain public meetings. When the user goes to a certain web page & signs up to speak at the public meeting, I want to - with absolutely no further involvement of the user - create a new attendee for a meeting which will have been previously created. They shouldn’t have to follow a link or do anything else at all.

I tried making a request to https://zoom.us/oauth/authorize accompanied by the required three parameters, but that got me no response at all. As in all I got back was literally “0”. Just the number 0, nothing else.

Hi @mark.krawec,

I’ve since connected with you over email, so I will continue the conversation there!

Thanks,
Will

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.