ERROR TypeError: Cannot read property 'toString' of undefined in ZoomMtg.join function

@tommy
Description
Getting ERROR TypeError: Cannot read property 'toString' of undefined error while joining the meeting.

Which version?
@zoomus/websdk”: “^1.7.5”

Screenshots

Additional context
I tried with the latest version 1.7.7 but the problem persists
It is working on Local machine but not on Production

1 Like

Facing the same issue. Were you able to resolve it?
@michael.harrington Are you able to assist?

No, not yet. Waiting for their reply. It’s super urgent!
@tommy, @Michael_Purnell

try creating meetingConfig variable and pass to join()

var meetingConfig = {
meetingNumber: this.meetingNumber,
userName: this.name,
userEmail: this.email,
signature: this.signature,
apiKey: this.apiKey,
passWord: this.password,
success: function(res){
$(’#nav-tool’).hide();
},
error: function(res) {
console.log(res);
}
}

ZoomMtg.init({
leaveUrl: this.returnUrl,
success: function () {
ZoomMtg.join( meetingConfig );
},
error: function(res) {
console.log(res);
}
});

it is not giving me toString() error

I tried this solution, but the error persist…

I debugged this issue in Zoom library, the error is in file zoomus-websdk.umd.min.js and on line meetingNumber: e.meetingNumber.toString()
I tried with latest SDK 1.7.8 also.
It is not working on Local as well

Hey @nilesh.bunde,

Can you please share your init and join meeting code snippets along with steps to reproduce the issue so I can debug?

Thanks,
Tommy

Hi @tommy,
The issue got resolved in v1.7.8

Thanks

1 Like

You are welcome! :slight_smile:

@a.s.masilo are you still having issues?

Thanks,
Tommy

Hi Tommy and thanks for checking. I was, after upgrading to 1.7.8 I had a jquery issue (turned out I had two jquery references). It seems to be resolved now. Thank you.

1 Like

Hey @a.s.masilo,

Thanks for sharing your solution! Glad you figured it out! :slight_smile:

-Tommy