Error with react-native-zoom-video-sdk "Unable to resolve module react-native-zoom-video-sdk"

I am encountering an error while attempting to use the react-native-zoom-video-sdk in my React Native project. The error message I’m receiving is as follows:

Error: Unable to resolve module react-native-zoom-video-sdk from /<path>/App.js: react-native-zoom-video-sdk could not be found within the project or in these directories:
node_modules
  10 | import { View } from 'react-native';
> 11 | import { ZoomVideoSdkProvider, useZoom, EventType  } from 'react-native-zoom-video-sdk';

This error occurs when attempting to import components from the react-native-zoom-video-sdk package in my App.js file. I have ensured that the package is installed in my project’s node_modules directory, but the error persists.

Dependencies:

"dependencies": {
  "@zoom/react-native-videosdk": "^1.10.10",
  "react": "18.2.0",
  "react-native": "0.73.6"
}

Steps Taken:

  1. Tried installing @zoom/react-native-videosdk using npm install @zoom/react-native-videosdk.
  2. Also attempted installation using yarn add @zoom/react-native-videosdk.
  3. Followed by running pod install to ensure iOS dependencies are properly linked.

System Environment:

  • OS: macOS 14.3.1
  • CPU: (12) x64 Intel(R) Core™ i7-9750H CPU @ 2.60GHz
  • Memory: 28.36 MB / 16.00 GB
  • Shell:
    • Version: “5.9”

Binaries:

  • Node:
    • Version: 21.5.0
  • Yarn:
    • Version: 1.22.22
  • npm:
    • Version: 10.5.0
  • Watchman:
    • Version: 2023.12.04.00

Managers:

  • CocoaPods:
    • Version: 1.15.2

SDKs:

  • iOS SDK:
    • Platforms: DriverKit 23.4, iOS 17.4, macOS 14.4, tvOS 17.4, visionOS 1.1, watchOS 10.4
  • Android SDK:
    • API Levels: “31”, “32”, “33”, “34”
    • Build Tools: 30.0.2, 30.0.3, 31.0.0, 33.0.0, 33.0.1, 34.0.0

IDEs:

  • Android Studio: 2023.2 AI-232.10227.8.2321.11479570
  • Xcode:
    • Version: 15.3/15E204a

Languages:

  • Java:
    • Version: 17.0.10
  • Ruby:
    • Version: 3.3.0

npmPackages:

  • react:
    • Installed: 18.2.0
  • react-native:
    • Installed: 0.73.6

Hi @prasanth you’ll need to import from "@zoom/react-native-videosdk" package.

Like so:

import { ZoomVideoSdkProvider, useZoom, EventType  } from '@zoom/react-native-videosdk';

Here’s a sample for your reference: VideoSDK-ReactNative-Quickstart/App.tsx at main · zoom/VideoSDK-ReactNative-Quickstart · GitHub