Error with ZoomWebSDK2.2.0, error with function

Description
Updated to SDKv2.2.0 and while running it is giving the error with function.
ERROR in node_modules/@zoomus/websdk/index.d.ts

Browser Console Error

Which Web Meeting SDK version?
2.2.0

Meeting SDK Code Snippets
Updated WebSDK1.9.9 to 2.2.0 and try to run and it is giving below error.

To Reproduce(If applicable)
Updated WebSDK1.9.9 to 2.2.0 and try to run and it is giving below error.

Screenshots

Device (please complete the following information):

  • OS: Windows 10 Pro, 64-bit operating system
  • Browser: Version 99.0.4844.51 Chrome is up to date

@MaxM, @donte.S Can you guys please help me with this.

@tommy, any idea why is this happening.

Hi, @vbhosale,

Thanks for posting! This is a known issue and will be fixed in the next version. For your concern, please see the change log and post below for guidance :

CEC9D75A-70C9-4CBC-BFCB-181A5353A430

Best,
Donte

Hey, @donte.S thanks for that, It is working.

One question there is line, “If you are setting the dependent assets to the Zoom CDN, there is no issue. For example:
ZoomMtg.setZoomJSLib(‘https://source.zoom.us/2.2.0/lib’, ‘/av’);”

this is for what?

Hi, @vbhosale,

Glad to hear that resolved the issue. Regards your question, are you asking what is that setter used for? If so, it is used to set zoom default requirements lib resource. To learn more you can check the Zoom Web SDK Reference here:

https://marketplacefront.zoom.us/sdk/meeting/web/ZoomMtg.html#setZoomJSLib

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.