Failing to to start a meeting using the zoom meeting web SDK reason Not support start meeting via tokens

I’m using the meeting SDK (web) and I’m trying to start a meeting (joining a meeting with a zak token worked)
I’m using my own licensed user to start the meeting.
I’m getting the following error:
errorCode: 200
reason: “Not support start meeting via tokens”

I’m using the following api to get a zak token:

Tried with version 2.9.7 and 2.9.5

Also tried editing the relevant parts in the sample app and then start a meeting, perhaps if you could share you own snippet of a code that starts a meeting successfully that would be a good starting point for the debugging

  • Device: laptop
  • OS: Windows 11
  • Browser: Chrome/firefox
  • Browser chrome: 110.0.5481.78

thanks, Roy.

Here are the sessions regarding WebSDK Integrations

Hi @roykarseboom
Have you taken a look at our Meeting SDK sample app?

Hi, thanks for the response.
regarding @freelancer.nak response:
As far as I can tell the video demonstrate how can I join the meeting rather then start it using the client. As I mentioned, joining is already something I have successfully done.

regarding @elisa.zoom
Yes, I have ran it locally, though it seems to only allow joining a meeting rather then creating one.

By the way, a method that did work for me which is creating a zoom meeting using the ouath API and then supply the the zak token that was present in the response into the meeting client, though If I understand correctly this is a work around rather then the way things actually suppose to be, correct me if I’m wrong here though.
Also if you have any suggestion on how to make ‘starting a meeting work’ please let me know.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.