Got black screen while joining meeting

Description:
when i try to join meeting i got black screen, earlier it work work but now it gives balck screen. when i generate signature at server side using php it gives me an error of “joining timeout” No Permission I also change the version but still getting the same issue.

Hi @vikashkeswani,

Can you please provide your signature, code snippet or a link to your repo, and steps to reproduce? I’ll be happy to help debug once I have this information.

Thanks,
Will

I have tried these two ways for signature generating but got same issue of black screen. first I used this way for signature

meetingObject:
const meetConfig = {
apiKey: API_KEY,
meetingNumber: ‘75048289765’,
leaveUrl: ‘https://127.0.0.1:8000/meeting_end’,
userName: ‘vikash keswani’,
userEmail: ‘vikashkeswani@gmail.com’,
passWord: ‘123456@0’, // if required
role: 1, // 1 for host; 0 for attendee
lang: “en-US”,
signature: “”,
china: false
};

signature method:
const meetsignature = ZoomMtg.generateSignature({
meetingNumber: meetConfig.meetingNumber,
apiKey: API_KEY,
apiSecret: API_SECRET,
role:meetConfig.role,
success:function(res){
meetConfig.signature = res.result ;
}
}) ;

then I uses this php method for signature:
function generate_signature (Request $request){
// $api_key, $api_secret, $meeting_number, $role
$time = (time() * 1000) - 30000;//time in milliseconds (or close enough)

    $data = base64_encode($request->api_key . $request->meeting_number . $time . $request- 
    >role);  

    $hash = hash_hmac('sha256', $data, $request->api_secret, true);
    $_sig = $request->api_key . "." . $request->meeting_number . "." . $time . "." . $request->role . 
     "." . base64_encode($hash);

    //return signature, url safe base64 encoded
    return rtrim(strtr(base64_encode($_sig), '+/', '-_'), '=');
}

Currently I am using Basic (Free) Zoom account for developing

waiting for the response

Hi @vikashkeswani,

I noticed that you mentioned you’re using a free account—in order to host a meeting through the Web SDK, you will need a Pro or higher plan:

Please upgrade your plan in order to host meetings through the Web SDK.

Thanks,
Will

Earlier it was working now it is showing black screen. is there any reason

Hey @vikashkeswani,

What version of the Web SDK are you using? Can you also please provide a screenshot of the issue?

Thanks,
Tommy

Currently I am using Web SDK version 1.8.1 earlier it was working but now it shows black screen I tried javascript signature method as well as with php. when I generate signature using php method it gives me an error of joining meeting timeout No Permission.

and when i use javascript method for signature it shows black screen with message in console that meeting joined successfully.

Currently I am using Free Basic account for developing this project earlier it was working but Now it shows these issues. and I am using this websdk in laravel project.

Hey @vikashkeswani,

Can you also please share your Web SDK signature for a test meeting so I can debug?

Thanks,
Tommy

For some reason changing the css of zmmtg from position:fixed to position: absolute cleared it up for me

this is my websdk signature:

signature Tlo5RUdFUDJTV3VyVDVfR3VTRUxYZy43OTM2NTcwODEwOS4xNjAyNjcwMDQ5NDYxLjEuckJGSGdTTzAzRTQ1QnhNendXSHpRYnJCaHBuayt6ZUUyb0toK0VuT2ZKaz0

My black screen or green screen only shows up when I do a Share Screen and click both boxes. If you only click the box on the left at the bottom your screen share will always work. So if you see a black screen when joining someone’s meeting, most likely the presenter has both boxes at the bottom checked. Only check the one on the left.

anyone down to do a zoom call rn :speech_balloon:

Happy to hear you got it sorted out @aaga! :slight_smile:

Thanks,
Tommy

Hey @alexus.ventimiglia,

Did you need help with the Web SDK?

Thanks,
Tommy

Hey @vikashkeswani,

Your signature looks correct, however, you are on a free plan which could be causing the issue.

Please upgrade to Pro and try again.

Thanks,
Tommy

Thanks for sharing this @mnoelte! :slight_smile:

-Tommy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.