graphQL APIs result in {"error_msg":"404 Route Not Found"}

I have created a OAuth (& tried with Server-To-Server OAuth too) app on zoom. Provided the necessary details and ticked all the scopes i.e. granted all the permissions.

I generated an access token using API calls by passing the app credentials from Postman. then, I try to call a graphQL API with the generated access token, I get a {“error_msg”:“404 Route Not Found”}. If I use a JWT token to hit the graphQL API, it does generate a 200 response. If I use the OAuth generated access token to hit the REST APIs, it generates a 200 response.

HTTP Method - POST
Header - Authorization : Bearer
Content-Type: application/json
Query -
“scope”: “iq_conversation:read phone_recording:read zoom_events_registrants:write workspace:write contact_center_recording:read recording:write zoom_events_tickets:write imchat:userapp contact_center_note:write iq_coaching:read iq_comment:write contact:read zoom_events_basic:write chat_channel:write phone_sms:write user:write meeting:read:sip_dialing chat_message:write app:deeplink:write zoom_events_tickets:read phone:read iq_deal:read zoom_events_ticket_types:read app:deeplink:read whiteboard:write zoom_events_sessions:read iq_conversation:write marketplace_app:read user_info:read user_zak:read whiteboard:read phone:write meeting_token:read:live_streaming chat_message:read zoom_events_hubs:read meeting:read phone_recording:write recording:read zoom_events_reports:read webinar:read webinar_token:read:live_streaming phone_call_log:write zoom_events_basic:read webinar_token:read:local_recording phone_call_control:write marketplace_entitlement:read user:read zoom_events_attendee_actions:read zoom_events_ticket_types:write phone_e911:read contact_center_inbox:read phone_voicemail:read app:channel_content:write contact_center_note:read chat_channel:read chat_contact:read tsp:read meeting:write:sip_dialing zoom_events_attendee_actions:write tsp:write pac:read zoom_events_registrants:read phone_call_log:read webinar:write phone_call_control:read iq_comment:read meeting:write pac:write phone_sms:read zoom_events_sessions:write iq_playlist:read zva:read:km_kbs phone_voicemail:write meeting_token:read:local_recording workspace:read iq_analytics_metrics:read zva:write:km_kbs”

What am I doing wrong here?

@ojus.zoom, been stuck with this issue for a long time. Any inputs?

1 Like


the URL is

I am experiencing the same problem: I am getting HTTP 404 with {"error_msg":"404 Route Not Found"} in the body of the response when I try to dispatch a GraphQL query. I am using the same URL as @mahesh.baliga because that’s what the “Introduction to GraphQL” section in Zoom’s documentation says:

Here is the Zoom GraphQL endpoint:

Based on @ojus.zoom response, I figured maybe the documentation is wrong so I tried a bunch of alternative URLs such as:


but I get HTTP 404 in all these cases. I can’t figure out the correct URL. In the screenshot below, you can see my many attempts that resulted in HTTP 404 Not Found:

Hi @desautelsj In my case, it turned out to be the permissions that were set on my user. Do check that.