Hide invite option on participant UI

Hide invite option on participant UI

HI,
I want to hide invite option on participant screen. i am using custom UI for zoom calls.
Sample Code
StartMeetingOptions opts = new StartMeetingOptions();

	opts.no_driving_mode = true;
	opts.no_titlebar = true;
	opts.no_bottom_toolbar = true;
	opts.no_invite = true;

ZoomSDK.getInstance().getMeetingSettingsHelper().disableChatUI(true);
StartMeetingParamsWithoutLogin params = new StartMeetingParamsWithoutLogin();

int ret = meetingService.startMeetingWithParams(this, params, opts);
below is the screen shot of the issue.

Hi @rohit.bhainwal, thanks for the post.

Please note that I have moved your post over to the #client-mobile-sdk category. :slightly_smiling_face:

Since you are using a custom UI, the meeting options you are setting will have no effect. When implementing a custom meeting UI, you are solely responsible for maintaining the behavior and appearance of the views in your UI. The SDK cannot access the UI you implement in your app.

Thanks!

Hi @jon.lieblich
Thanks for the update.

I would like to inform you that the attachment in the above post you can see is not the Custom UI. it is the default Participant UI of zoom.I have just customise the Video call. In IOS we have used this code “setting?.meetingInviteHidden = true” to hide invite button. and it is working in IOS

We used similar approach in both ios and Android. so why the same functionality is behaving in different way.
It would be helpful if i get some understanding on this.

Hi @rohit.bhainwal,

Apologies for the misunderstanding, the participants UI on my device has a different appearance than the one in your screenshot.

The behavior you are describing is unfortunately not currently supported on the Android SDK. Since this is already available on the iOS SDK, I would be happy to submit a feature request on your behalf to achieve parity between the two platforms. I will be sure to let you know as soon as we have an update.

Thanks!

Hi @rohit.bhainwal,

Can you please confirm which version of the SDK you are using? After additional testing, I have determined that setting the no_invite field to true on MeetingOptions, the invite button is correctly hidden on the participants UI, even with custom UI enabled.

Thanks!

Hi @jon.lieblich,

I have used version no: v4.6.21666.0429 in my Android app. If there is any latest version please provide me the link of it.

Hi @rohit.bhainwal,

Unfortunately I cannot provide a direct link to download the most recent version of the SDK. In order to download it, you will need to login with your developer account on the marketplace, navigate to your dashboard, select your SDK app, navigate to the Download category, and then click on the Android icon to download. Please let me know if you encounter any issues with this new download flow and I will be happy to help.

Thanks!

Hi @jon.lieblich,

Thanks for the update. After changing the SDK version, I am able to hide the invite button. But now chat button is also getting hide. I have used “ZoomSDK.getInstance().meetingSettingsHelper?.disableChatUI(false)” But still I am not able to view the chat button.
Can you please help me in this?

Thanks.

I have utilized form no: v4.6.21666.0429 in my Android application. In the event that there is any most recent form if it’s not too much trouble, give me its connection.

Hi @rohit.bhainwal,

The chat button should be located in the default UI under the More button in the bottom right corner. Can you please confirm whether or not this is present in that menu?

Thanks!

Hi @alexroberto5511, thanks for using our SDK.

Can you please follow the instructions in my previous reply and let me know if you are running into any issues with accessing the latest SDK version through that flow?

Thanks!

Hi @jon.lieblich,

please go through the attachment, in that you can see the chat button, but that is the old version. As now I have updated the sdk version, in that chat button is also getting hide. is there any issue with the latest sdk. Dose it support the “ZoomSDK.getInstance().meetingSettingsHelper?.disableChatUI(false)” code. I don’t think the latest sdk support this code. due the which there is no any effect on the participant UI.
It only hide and unhide the invite button. As in the older version it used to hide and unhide the chat button and invite button used to be visible all the time, similar issue is there in the latest version also only the button has changed the visibility. In older version the Invite button used to be always visible and in the latest version Chat button is always hidden.

can you please help me in making the chat button visible. As in the ios the we are able to handle chat button visibility with the latest version.

Thanks


Older version participant screen


Latest version participant screen: No chat button
used code : - ZoomSDK.getInstance().meetingSettingsHelper?.disableChatUI(false)

Hi @rohit.bhainwal,

The chat button has been moved from that location in the default UI. It is now located in the More menu in the bottom right. If you would like the chat button to appear in the participants menu, you would need to implement a custom meeting UI.

However, if you are not seeing the chat button in the new location, that is a different issue. Please let me know if that is the case. :slightly_smiling_face:

Thanks!