How to create a user by ZOOM API with "autoCreate" action


#1

when I request like this:
POST https://api.zoom.us/v2/users
(
‘action’ => ‘autoCreate’,
‘user_info’ =>
array (
‘email’ => ‘lalala17_23@abc.com’,
‘type’ => 1,
‘first_name’ => ‘’,
‘last_name’ => ‘’,
‘password’ => ‘123123’,
),
)

and got response :{“code”:300,“message”:“Validation Failed.”,“errors”:[{“field”:“user_info.password”,“message”:“Invalid field.”}

any ideas?


#2

Hi @daimoon.hunter,

To use auto create do you have managed domain enabled? Also, have you tried to create a user using curl command or within postman to make sure the code isn’t interfering with the API call?

Thanks


#3

Hi Michael thanks for reply
I just approved managed domain in account profile.


and try with API tools

still not working


#4

Hello @Michael_Purnell can you help me with this problem?
I really need this feature


#5

Hi @daimoon.hunter,

The password has to have a minimum of 8 characters and maximum of 32 characters.

Let us know if that works.

Thanks


#6

Hello @Michael_Purnell
It works , thank you very much!
I didn’t notice the rules of the password,it’s my fault


#7

No worries, glad we can help you out!