How to update "plan_bundle" named hosts with REST API?

Description/Error

Attempting to update a sub-account’s number of available hosts via the REST API, but have not been able to do so since they have upgraded to Enterprise Named (Tier 2).
I’ve noticed that they are now listed as “plan_bundle” as an object when retrieving their plan information (via GET /accounts/:accountId/plans).

Eg:

    "plan_bundle": {
        "hosts": 105,
        "active_hosts": 0,
        "bundled_plans": [
            {
                "type": "PLANCODE_1122"
            },
            {
                "type": "large500_yearly"
            },
            {
                "type": "webinar500_yearly"
            }
        ]
    }

Previously, their plan type was business_yearly, and we would just use PUT accounts/:accountId/plans/base to set the # of hosts to the desired number.

Does anybody know how to update the number of named hosts for an Enterprise account (with plan_bundle)?

Thank you :slight_smile:

Hey @Rob_Di_Toro, thanks for using Zoom and the detailed post!

Have you tried the PUT /accounts/{accountId}/plans/addons endpoint?

“Update an additional plan for a sub account.”

Also are you getting any errors, or does it just not work?

Let me know if this works!

Thanks,
Tommy

Hi Tommy,

Thanks for the reply.

Yes I have! Unfortunately much of the same result. The Enterprise Bundle (“PLANCODE_1122”) doesn’t appear to be a supported plan type, which is odd. Unless I’m doing something else wrong?

Postman screenshot of the add-ons API PUT call:

Hey @Rob_Di_Toro, happy to help!

Have you tried passing in "plan_bundle" instead of "PLANCODE_1122"?

Thanks,
Tommy

PUT /v2/accounts/{{accountId}}/plans/bundles

{
  	  "type" : "ENT-LMT_500-WBN_500-yearly",
	  "hosts": "100"
}

The Get Plan API response has plan type in the format PLANCODE_1122, but in the request to subscribe and/or update, we had to pass in a different string as above. I am not sure if that is a universal plan name or if it is configured specifically for our account.

1 Like

Thanks for posting this @sassy :slight_smile:

-Tommy

Hi @sassy,

Thanks so much for responding!

Unfortunately it didn’t work for me – I tried ENT-LMT_500-WBN_500-yearly as you suggested, but received the following response:

I also tried the PLANCODE_1122 for the same .../plans/bundles API call, but received the same response.

Any ideas?
Sorry for the late reply!

Thanks,
Rob

Hey @Rob_Di_Toro,

This sounds like the string ENT-LMT_500-WBN_500-yearly @sassy provided is custom to his account.

Can you reach out to support@zoom.us or your Zoom account executive to have them tell you what plan type code to pass in?

Thanks,
Tommy

Will do, @tommy.
Thank you :slight_smile:

Rob

1 Like

You are welcome! :slight_smile:

Let us know if using your plan code string works!

Thanks,
Tommy

That’s correct. @Rob_Di_Toro Our contact at Zoom mentioned that the plan bundle names like the one I provided are custom built for each company and that they have to be configured and made available for each account. Also, as I mentioned the request doesn’t take type in the format PLANCODE_XXX, but once configured with something like ENT-LMT_XXX, it does return that value. We are trying to find out if there is any mapping between ENT_XXX and PLANCODE_XXX formats.

1 Like

Thanks for posting this @sassy! This is really helpful! :slight_smile:

-Tommy

Hi all,

Got it resolved finally– I actually passed the same plan code as @sassy:
(ENT-LMT_500-WBN_500-yearly), but I needed to contact Zoom Support first to have something ‘enabled’ on my account.

I suspect that I didn’t have the correct permissions scope to enact changes on the /bundles API.

Thanks for your help, everyone :slight_smile:

Rob

1 Like

Happy to hear we got it working! :slight_smile:

Let us know if you have any other questions!

Thanks,

-Tommy