I got '400 : {"reason":"Invalid request : Redirect URI mismatch.","error":"invalid_grant"}' error after my ngrok re-started

API Endpoint(s) and/or Zoom API Event(s)
Oauth with Zoom

Yesterday I succeeded getting access token, refresh token, and get information /me.
But today I re-started ngrok(free plan), so my domain is changed.
so I changed zoom app’s settings, and my code’s uri domain changed.
but after that, I always got the same error even I succeeded yester with this code.

{“reason”:“Invalid request : Redirect URI mismatch.”,“error”:“invalid_grant”}

I checked my server’s redirect code,
zoom market place’s settings,
all the redirect uri was same.

This is my local server’s redirect log.

Redirected to https://zoom.us/oauth/authorize?response_type=code&redirect_uri=https://e2a7-222-114-152-95.ngrok.io/oauth/zoom_callback&client_id=blabla

This is my app credentials.

Redirect URL for OAuth
Destination URL where Zoom will send the access token after the user completes the OAuth authentication.

Add allow lists

as you can see, all redirect uri is same.

What should I re-check for solving this error?

400 : {“reason”:“Invalid request : Redirect URI mismatch.”,“error”:“invalid_grant”}

Please let me know what should I check more.

I solved this issue by my self.
The problem was get access token api.
I sent different uri when I call get access token api after I redirected to my callback.
I’m going to next step.