Including the MobileRTC.xcframework & MobileRTCResources.bundle in Development pod

Not able to include MobileRTCResources.bundle in Development pod

Which iOS Meeting SDK version?

To Reproduce(If applicable)
in my podspec file, I added below line, this successfully added MobileRTC into my pod code
s.vendored_frameworks = “MobileRTC.xcframework”

But for including MobileRTCResources.bundle, I tried different podspec like .resource, resources, resource_bundles, etc. Nothing working
Getting below error when I try to initialise meeting SDK

2022-02-01 15:02:21.137323+0530 ZoomSample[9833:3347834] old data has cpoied done
2022-02-01 15:02:21.762055+0530 ZoomSample[9833:3347834] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: '* -[NSBundle initWithURL:]: nil URL argument’**
***** First throw call stack:**
(0x1807bd04c 0x198e31f54 0x181feb904 0x181fc051c 0x10a853928 0x10521e3b4 0x10521ff84 0x10a853854 0x10b1daaf0 0x10c1aa5f4 0x10c195820 0x10c2c7c74 0x10c2c18f0 0x10c2c8bf4 0x10a8f7eec 0x10ab6f078 0x10b2933b0 0x10b2eca08 0x10b2ec8c0 0x10b2e6560 0x10b2e5cbc 0x10b1aeecc 0x10b1aee98 0x10a87e3f0 0x181f786ec 0x1807d2268 0x180756c40 0x18075143c 0x18072fc58 0x1807433b8 0x19c0d338c 0x1830e36a8 0x182e627f4 0x197e5c184 0x104fb4460 0x104fb43e8 0x104fb48f4 0x105331a24)
libc++abi: terminating with uncaught exception of type NSException
dyld4 config: DYLD_LIBRARY_PATH=/usr/lib/system/introspection DYLD_INSERT_LIBRARIES=/Developer/usr/lib/libBacktraceRecording.dylib:/Developer/usr/lib/libMainThreadChecker.dylib:/Developer/Library/PrivateFrameworks/DTDDISupport.framework/libViewDebuggerSupport.dylib
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘*** -[NSBundle initWithURL:]: nil URL argument’

terminating with uncaught exception of type NSException

To confirm if this issue is with “MobileRTCResources.bundle”, I deleted it from regular example app (not cocoa pod/lib), I got same error

Smartphone (please complete the following information):

  • Device: iPhone 13
  • OS: iOS 15.1.1

Hi @sambasiva.r.dodigam, thanks for using the dev forum.

Are you able to add the SDK to your project through the instructions outline in our documentation?


@jon.zoom Yes for a project (app), I am able to add SDK & .bundle without any issues. But for cocoa pod not. Pod is not able to find bundle path

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.