MobileRTC(Zoom integration in iOS)


#1

Hii,
I am a iOS developer. I am trying to integrate a zoom iOS SDK into my app, but i’m getting error “this framework not found MobileRTC”. I have copied two framework into my app 1)MobileRTCResources.bundle 2)MobileRTC.framework.
I have tried in another way means as per documentions (https://developer.zoom.us/docs/ios/development-environment-setup/) we need to also import “libsqlite3.tbd”, “libstdc++.6.0.9.tbd”, “libz.1.2.5.tbd”, “VideoToolbox.framework” and “CoreBluetooth.framework” into “Link Binary With Libraries” but in Xcode 10.1 “libstdc++.6.0.9.tbd” does not support. Please guide me on this. Does this frameworks also necessary?

Questions

  1. Any other framework i need to integrate other than MobileRTCResources.bundle and MobileRTC.framework
  2. Does this framework supports in Xcode version 10.1 (latest version of Xcode)
  3. libstdc++.6.0.9.tbd this framework does not support in Xcode 10.1
  4. Can you give me a proper step by step procedure to integrate iOS SDK

#2

Hi,
First of all, thank you for using our SDK.
The SDK supports xcode10.1.
Before Xcode10,use libstdc++.6.0.9.tbd,After Xcode10 use libc++.
For integration issues, pls use our latest documentation:https://marketplace.zoom.us/docs/sdk/iOS
Any questions can be asked here.
Thanks
Murray


#3

Hi,
When i click on this link (https://marketplace.zoom.us/docs/sdk/iOS) i’m getting Oops! This page doesn’t exist.


#4

Hi,
Now i am able to integrate it. I have added all keys (like appkey, appsecret) but when i run the app i am getting error “ld: symbol(s) not found for architecture x86_64”, “clang: error: linker command failed with exit code 1 (use -v to see invocation)”. I am attaching screenshot

please check it and help me.


#5

Hi,
Please reply as soon as possible.


#6

Please download SDK from: https://github.com/zoom/zoom-sdk-ios/releases, the latest SDK package is: ios-mobilertc-all-4.3.30728.0118-n.zip. This package included Device and Simulator mode.


#7

Hi~
try this: https://marketplace.zoom.us/docs/sdk/native-sdks/iOS
Thanks


#8

Hi there! Getting the same error. Followed all the instructions. Not sure if it’s something on your end?

Also as an unsolicited suggestion why don’t you guys release your SDK as a pod instead? It’s much easier to deploy and maintain.


#9

Hi,

Thanks for using Zoom SDK. This issue might be similar to this: https://stackoverflow.com/questions/32687105/framework-not-found-in-xcode and it might not be a Zoom SDK specific issue. This issue usually happens when the library is located outside the root folder of the project, please double check the path of the reference or when you add the framework, you can select “Copy if needed” to ensure the libraries are in the project.

Thanks!


#10

Thanks that helped. It was a indeed a path issue.


#11

Hey, thank you so much for this link.
Now when is click on start meeting i am getting sometime this error

start meeting ret: Optional(__C.MobileRTCMeetError(rawValue: 0))
onMeetingStateChange: MobileRTCMeetingState(rawValue: 1)
Warning: Attempt to present <ZMNavigationController: 0x15696c000> on <AP_Guru.Splash_VC: 0x156841a00> whose view is not in the window hierarchy!
AP_Guru.Splash_VC is my project and file name

and also Optional(__C.MobileRTCMeetError(rawValue: 152)) this error also

My code on start button ->

DispatchQueue.main.async
{
let service = MobileRTC.shared().getMeetingService();
if (service == nil){
return;
}

        service?.delegate = self;
        let meetingId = self.classModelArray[index].zoom_id
        print(meetingId)
        
        let settings = MobileRTC.shared()?.getMeetingSettings()
        settings?.meetingVideoHidden = false
        settings?.bottomBarHidden = false
        settings?.disableDriveMode(true)
        settings?.topBarHidden = false
        settings?.meetingInviteHidden = true
        settings?.meetingShareHidden = true
        settings?.setMuteVideoWhenJoinMeeting(false)
        let rtc_username = UserDefaults.standard.string(forKey: "stud_name")!
        print(rtc_username)
        
         //kMeetingParam_UserType: "99",
         let dic = [kMeetingParam_UserID: self.rtc_userid,
                           kMeetingParam_UserToken: self.rtc_token,
                   kMeetingParam_Username: rtc_username,
                   kMeetingParam_MeetingNumber: meetingId,
                   ];
        let ret = service?.startMeeting(with: dic);
        
        print("start meeting ret: \(ret)");
        }

#12

Hi,

Thanks for the reply and the details. Regarding the error codes, you can refer to the error code table in our document: https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/resource/error-codes

  1. start meeting ret: Optional(__C.MobileRTCMeetError(rawValue: 0)) -> error code 0 means success
  2. onMeetingStateChange: MobileRTCMeetingState(rawValue: 1) -> error code 1 means “Network issue, please check your network connection”
  3. Optional(__C.MobileRTCMeetError(rawValue: 152)) -> error code means “The user joins already in another ongoing meeting”.

Regarding the warning: Attempt to present <ZMNavigationController: 0x15696c000> on <AP_Guru.Splash_VC: 0x156841a00> whose view is not in the window hierarchy!
This warning might be related to the root navigation controller setting at initialization. If your app’s rootViewController is a UINavigationController, then you need to set:

[[MobileRTC sharedRTC] setMobileRTCRootController:navVC];

If not, you don’t need to call this method. For more info, please refer to the instruction in the doc:

Let me know if you have any other questions.

Thanks!


#13

Hi,
Thank you.That error code link helped me to understand more in details. But I want to understand more about error 152.

  1. I am not using UINavigationController that you suggest solution for Warning: Attempt to present <ZMNavigationController: 0x105962e00> on <AP_Guru.Splash_VC: 0x10580fc00> whose view is not in the window hierarchy!
  2. so this Warning and error code 152 occurred when i killed the app and try to click on start button nothing happened on click
  3. scenario - first time i have installed my app and click on start button it works. now i have ended meeting from host i clicked on start button it open the window with message “waiting for the host to start this meeting” and tried vice versa its work, now when i killed my app or run the app and click on start button nothing happen
    4)I have also refer this two link https://support.zoom.us/hc/en-us/community/posts/360028714831-Getting-Error-MobileRTCMeetError-rawValue-152-while-customising-Waiting-UI-for-iOS-

https://devforum.zoom.us/t/getting-error-mobilertcmeeterror-rawvalue-152-while-customising-waiting-ui-for-ios/1855

  1. My code is this func onJoinMeetingInfo(_ info: MobileRTCJoinMeetingInfo, completion: ((String?, String?, Bool) -> Void)!)
    { } But i don’t understand how to pass value in that. I have also refer your sample app but not found any solution

Could you guide me as to what may be going wrong here?


#15

Hey, Hi
Any update on this point?
Please reply as soon as possible.

Thank You.


#16

Hi,

Pardon the late reply.

  1. Regarding the " Warning: Attempt to present <ZMNavigationController: 0x105962e00> on <AP_Guru.Splash_VC: 0x10580fc00> whose view is not in the window hierarchy!", we are investigating this issue and we will get back to you once we have more info on this.
  2. The error code 152 means “Already in another meeting”, so when you are in a meeting(when you see the message “waiting for the host to start this meeting”, you are in a meeting, just the meeting not yet started by the host), and then kill the app, the session established between you and our Zoom server still valid and exist. If you try to use the same info to join the meeting again, you will get the error code 152.
  3. Regarding the code snippet you mentioned, you don’t actually need to pass values into it, once you implement it, the SDK will take care of the parameters passed into it.

Let me know if you have any other questions. Thanks!