Insufficient Privilege error with GET /report/activities

/report/activities returns an insufficient privilege error when tried with credentials of account admin(License - Pro)

GET /report/activities returns HTTP 400 along with {"code":200,"message":"Insufficient Privilege."} when tried with OAuth token generated with the admin account under Pro plan. The same works with the token generated with the owner of the account under the same plan.

The doc mentions about the plan(Pro or higher plan) and required scope(report:read:admin) but not about the role of the user who generated the token.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. GET /report/activities with OAuth token generated with admin account under Pro license
  2. HTTP 400 with {"code":200,"message":"Insufficient Privilege."} is returned

Hey @augusta,

Can you share the userID of the user that is experiencing this error so I can investigate further?